DIY Home Improvement Forum banner
81 - 100 of 148 Posts

·
Registered
Joined
·
1 Posts
Older Kenmore portable dishwasher. Drain problem. How to access beyond the plastic screen to see if there's an obstruction. The screen doesnt seem to have an obvious screw or such to undo. Is it possible that with a screwdriver it snaps open?
 

·
Registered
Joined
·
94 Posts
I just ran accross that same simptom. The user interface board in the frig (digital display) and the light are feed from the big power board down by the compressor. Can't remember the exact tests I made but bottom line was I ordered the pwer board.
 

·
Registered
Joined
·
94 Posts
Just dropped in the power board. Problem solved. You can test the board by checking for line voltage from plug cn1 white wire to plug cn2 yellow with red striped wire. It should be 120 volts line voltage. This one was at 107 and would drop to zero when the door was opened.
 

·
Registered
Joined
·
1 Posts
Problem Solved!

I just wanted to add my thanks to those posting in this thread. I have a 3-year-old Whirlpool Gold and experienced the same problem described by many here about a week ago... lights out, relay chattering when the door was opened. I ordered a new control board and installed it in about 20 mins this afternoon... and everything's back to normal. Thanks again!
 

·
Registered
Joined
·
2 Posts
Same Here

Whirlpool gold side by side. 3 years (warranty I bought).. digital display and light went out one month later. Took bulb out and bulb still works..
Just ordered the part and it will be here in 3 days. Scheduled a service call and cancelled .. Thanks to everyone on this thread..Would have been $75 plus part instead of $85 total...
And like someone earlier in this thread... It's not a whirlpool control board in my unit.. hmmm... something isn't right... especially when they are sending me a whirlpool replacement....
 

·
Registered
Joined
·
2 Posts
Don't Pay A Tech

IF YOU HAVE A wHIRLPOOL GOLD SIDE BY SIDE WITH NO DIGITAL AND NO LIGHT AND THE FRIDGE WORKS...
$85.00 AND I DID IT MYSELF IN 5... LITERALLY 5 MINUTES.... ELECTRONIC CONTROL BOARD REPLACEMENT...
8 SCREWS FOR THE CARDBOARD AND 0 FOR THE POP OUT CONTROL BOARD...
THANKS A MILLION... EVERYONE WHO POSTED...:thumbsup:
 

·
noitall
Joined
·
42 Posts
Wire jumper

Add me to the victim list! I bought our fridge in 2004, had to replace the ice maker previous to this. I had the same lights out on the fridge side as everyone else here but not the clicking relay.
Would it hurt to leave the yellow/red wire connected to the circuit board? I used a Scotchlock to connect the yellow/red wire (where it comes out of the frig body just below the connector) to the solid black wire in the bundle that runs across the back. No cutting needed, just slid on the connector and squeezed it on.
Everything seems back to normal so far.
 

·
Registered
Joined
·
1 Posts
One more to the list...

Identical, but cooling works fine. I have an 04 that my wife bought at Lowes, light went out about a year ago and I have the chattering relay. I'm going to pull the card and see if I want to fix it - really seems pretty straight forward as I am a electrical kind of guy.

Please add me to the class action when it happens! Great info guys.
Jim
 

·
Registered
Joined
·
1 Posts
Hi,

Just wanted to say thanks to those who came up with the fix. (pigtail red/yellow to solid black) Worked great and saved me 100 bucks.

Tom
 

·
Registered
Joined
·
9 Posts
It's been a year since the board went out in my fridge. The new board is working fine. Has Whirlpool acknowledged a problem with these yet?
 

·
Registered
Joined
·
94 Posts
Hi,

Just wanted to say thanks to those who came up with the fix. (pigtail red/yellow to solid black) Worked great and saved me 100 bucks.

Tom

Would sure like to see the internal schematic to see what that exactly does. You could be defeating an enegy saving feature. ie: it may have only defrosted every 20 hours of compressor run time and now it defrosts every 8 hours whether it needs it or not. Or turning on the compressor when only the evap fan needs to come on. A lot of these boards will go into a default mode when they malfunction and just keep the frig cold and working. But not working right. Keep an eye on your electric bill to make sure you don't get an increase of $5.00 or $10.00 a month. Wouldn't take long to eat up the savings of not putting in a new board.
LG just came out with a new board for one of thier refrigerators because it didn't meet the energy star rating. The frig runs fine. But they figure it is costing about $7.00 a month more to run without the new board.
 

·
Registered
Joined
·
1 Posts
Worked- thanks

Thanks Musiccha, followed the instructions in regards to bypassing the board and all seems to work great! We never lost cooling, just had the lights and controller dark on the fridge-side with the buzzing whenever door was open. Appreciate saving hours studying schematic and/or the replacement of board. Aren't the internet, and forums like this, amazing!?!:thumbup:


Thanks
Jim

At the wiring harness near the center of the frig (behind the cardboard in the back) 3 wires come out from the body of the frige and goin the main harness. I cut the yellow/rd wire and taped the end that goes to the control box. I refed the other end (that goes into the connector leading into the frig body) by splicing it into the black wire located in the harness. This black wire is a 120v feed from the power cord.

What my fix did (I think) was reduce the load on the board and bypass the function that turns the light on and off while keeping the function that turns the display on and off. It also resulted in a kiss from my wife.:thumbsup:
 

·
Registered
Joined
·
504 Posts
i didn't feel like reading through all these posts, so don't know if anyone told you the poblem is the electonic control mounted in the rear at lh side,facing rear, in plastic box. PULL PLUG!! before servicing.
 

·
Registered
Joined
·
1 Posts
whirlpool control board

Hi guys
I have an older model whirlpool fridge freezer (S20BRSB21-A/G) and cannot find a provider for the control board. Any suggestions?
Gabriel

 

·
Registered
Joined
·
2 Posts
Originally Posted by wgm
Exact same problem... but i found this forum after the repair man just left $264 - 12-01-2007, 07:33 PM same exact pics as this post... exact same board & exact same burn & exact same symptoms... as everyone described... flickering light etc... 3 years old frig.

Whirlpool bad boards for sure someone need to start a class action suit, I am keeping my bad board in case someone does...


Well it's happened AGAIN - Bad Board for the third time - same exact problem - this will be my 3rd bad board... :furious::furious::furious:

Do I give up & junk this frig, I can't keep replacing every 3 to 6 months !!!

Wish we could find a class action lawyer ! Need a Lemon Law !!!

FSP W10135090 CNTRL ELEC Code 080404

2252189 ITW ISPRACONTROLS

Model G565HEXNQ00
 

·
Registered
Joined
·
1 Posts
Hi folks--I'm hoping someone can help me. I have similar issue as all the other parties above (GD5SHAXNB00). However, I don't have the clicking/buzzing sound, just no LED read out/lights not working and only on fridge side (cooling is fine). COuld it be the same issue as everyone else with the circuit board needing to be replaced? I secretly fear it may also be moisture that got in from cleaning it recently. If you were me, would you still assume it's the control board and try to replace that? I really don't want to pay for a technician.
 

·
Registered
Joined
·
1 Posts
Another one bites the dust!

Hi Folks,

Same problem, (3) year old Whirlpool Gold, Model (GS2SHEXNS00). Saw a blue flash from the upper left control light then the same drop off of the Settings LED's, lights, and buzzing from the Electronic Control Relay. I appreciate all of those who have gone before with this problem. I am currently using Scotch tape on the switch, and a LED tap light for lighting.

I will be repairing the board on my next day off. Thought the top light was burnt, but after replacing the bulb with a frosted one, went back with the original clear bulb and with the cover off could see the filament flashing with the relay on the control board.

Anybody reported this to Consumer Reports or any other federal agency to possibly get a recall?

Just a thought.

Thanks,

Tim
 

·
Registered
Joined
·
1 Posts
Hey yall. I just finished the board repair without replacing the transistor and the light and the control display are working fine. We''ll see if the ice maker gets back on the ball. Just a tip for you newbie solderers, make sure the repair wire you use is stranded and that you melt on the solder to the wire first and then solder again to the contact points on the board. There's not much room there for error. Thanks everyone!

John
 

·
Registered
Joined
·
1 Posts
Me Too

I also have the whirlpool side by side flickering control board problem.
Read all these (and other sites posts) and can not believe Whirlpool will not fess up to a defective part and replace it.
Just to make sure, I called them today armed with all this info. As others state, they deny there is such a problem.
I am in very bad financial state due to current economy and thus will have a dark refrigerator for a year or two.
Just does not seem right and I would love to be contacted when the class action suit takes place.
 
81 - 100 of 148 Posts
Top