DIY Home Improvement Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1997 vintage Trane XE80, which would cycle on for heat, Gas burners will light but for only a second or two then go off. The unit has a White Rogers Model 50A50-471 controller, The controller is flashing error code 5: Flame Sensed with Gas Valve Off. After reviewing post on this forum I remove and cleaned the flame sensor, no change. I then changed out the flame sensor with one from a second furnace. Same results.

Does this mean the controller need to be changes?

Thanks,
 

·
Administrator
Joined
·
42,484 Posts
Sensor has been cleaned. Other sensor was firing the other furnace.
Its not the flame sensor. A dirty flame sensor won't give you a Flame detected with gas valve closed error. Since if its dirty, it generally can't detect a flame.

Either a reversed electrical polarity, poor ground, or the board is bad. Those would be the common problems for that error code when there is no flame.
 
  • Like
Reactions: WaldoLake

·
Roofmaster
Joined
·
3,731 Posts
The controller board is held in with a few screws, in my case (carrier) one of those screws grounds the board to the frame of the furnace. Long use and the screw can back out a little, connection can corrode, No Ground. I would say loosen All screws a turn or two, spray with contact cleaner, and re tighten screws. By all screws I mean the thermostat leads too. Pull off the spades, spray, emory, spray, put back.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top