DIY Home Improvement Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hello All.

I have an 18year old Carrier 58GS050160GB Natural Gas furnace that has stopped working. It has worked with no problem all winter but I have had it off for the past week. I went to turn it on last night to take the chill out of the air but nothing.

The thermostat tells me it should be started and what I would expect is to hear the ignitor clicking but there was nothing. I tried to reset the lockout just in case but that did nothing. I smell no gas. That's as far as I've gotten.

I work in the engineering field so electronics and controls are not foreign to me. It's probably time for a new furnace but for curiosity sake, I'd like to try to pin point the problem.

Thanks to all for your kind help.
 

·
Banned
Joined
·
5,990 Posts
Ya' really need the schematic and theory of operation; for me it was free from Bryant, but mine uses only relay logic.
This documentation might be online somewhere for your furnace.

There are several sensors ANDed together that can prevent the furnace from starting, and their signals can valid or invalid.
"The controls include the gas valve, ignition control, ignitor, flame sensor, transformer, limit control, blower control board, and flame roll out switch."
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you for the reply Yoyizit.

Interesting. I wondering if that was the case with the controls. There is a schematic on the back of the service panel of the furnace but I'm just not sure where to start.

Thanks again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hi Kennzz,

Thank you for the reply. No, there is no draft fan.

It looks like we found the issue. My Father In-law came over last night and we went through the schematic very carefully and measured voltages. We traced the issue to the ignition Lockout / control box. There is a relay on that board that I would bet has failed. He took the board with him because he has a 24V relay, he'll replace and we'll try tonight.

Thanks for all thew kind responses and I'll post what the problem was when it's fixed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thanks for the tip. I work on mostly digital and solid state electronics as a profession, so dealing with relays is a little out of my realm. Thanks again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Just wanted to update this thread as closed.

The coil on the relay was bad. We replaced the relay and all is good.

Thanks again for all of the help.
 
1 - 8 of 8 Posts
Top