DIY Home Improvement Forum banner

Part identification for Honeywell VR8204H1006

409 Views 12 Replies 4 Participants Last post by  yuri
I have a Honeywell VR8204H1006 Intermittent Pilot Gas Valve on a Utica Boiler that is not firing (no spark) while the circulation pump, vent damper is all working.

I narrowed it down to this little part shown in the photo that is connected to the electrical circuit of the gas valve and sits at the edge of the combustion chamber and I'm having trouble identifying it. There's a little button/relay in the middle of the two electrical connections and when I press it in (I can hear a little click), the boiler fires up within 5 seconds and all is good...for a couple hours...then I see that the boiler is no longer heating, even though the pump is still circulating water to my zones. And when I click the little button in, all is good again.

My assumption is that this part is failing and a simple replacement will do the trick. Can someone help me identify it and where I can buy one? Thanks - Matt
See less See more
1 - 5 of 13 Posts
The picture is in my album to the left
Thanks Yuri and roughneck, that's very helpful. We had outdoor temperatures -15 Fahrenheit and below the last two nights, so I wonder if it's impacting the exhaust getting out or a buildup/blockage that was enhanced by the coldest temps of the winter so far. Sounds like a need to call a pro and get it resolved.
Following up on this post in case others come across it. I ended up replacing the flame rollout switch and it resolved my issues. It was a $15 part and 10 minute DIY job and in my case, saved me a trip from a technician.

I agree with others that if the flame rollout switch was doing it's job, that this could be a more dangerous situation. But a quick $15 job can first be tried, just in case the switch itself was bad. In my case, it worked.
yes, I should have mentioned that I had my annual inspection by professionals during this time and the CO levels were fine.
1 - 5 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.