DIY Home Improvement Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello,
First post here.

I have a Kenmore electric oven that has started to randomly reset itself. It just shuts itself off while I'm using it. Sometimes it comes back on immediately with the clock flashing 88:88:88, sometimes it stays off until I operate one of the controls. There appears to be no pattern as to when it will act up. I could be using any element on the stove, or I could be using the oven.

The model number is 6817192. I don't know how old it is. The oven came with the house and I only moved in 3 months ago.

Any assistance/ideas/direction would be greatly appreciated.

Thanks
 

·
Registered
Joined
·
53 Posts
I tried to look that model up and didn’t seem to be a good model number. The problem sounds like the main board (if your range has one) but can’t say for sure because a problem like this can be hard to diagnose even if I were at your house looking at it. But I like a challenge every now and then.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks for checking into it. I noticed from reading other posts that the model number didn't quite look like the others from Kenmore. I guess that might mean it's very old. Also, I'm in Canada, by the way. So maybe there is a different naming convention for models in Canada.

Thanks for the link. I'll be taking a look at it.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top