DIY Home Improvement Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a G43UF Lennox heater (6 years old). Two weeks ago, it began shutting off (after 20-30 sec) for the 3 cycles then getting the alternating red/green lights. So I replaced (NEW) the "Flame Sensor", "Ignitor", and cleaned the burner unit. The heater now stays on for 10+ min but eventually will again flame out for 3 cycles. Additionally, I've replaced the batteries in the thermostat. I'm not sure what else to repair or replace. :confused1:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I don't have it in front of me but it indicated that the problem was Heater is cycling 3 times then shut down or something else (it indicated there could be 1 of 2 problems but mine was the Shutdown after 3 cycles). The lights flash simultaneously when OK but the alternating flashes indicated the 3 cycle problem. After researching, I figured the problem was the Flame Sensor and I also changed the Ignitor but it was functioning just fine. Since I was all the way in, I also cleaned everything.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
G43UF Lennox heater still shuting off

I have a G43UF Lennox heater (6 years old) and is still shutting off after the 4 cycles. Here's what I've done so far: changed the thermostat's batteries, replaced the Flame Sensor and Igniter, removed, cleaned and replaced the burners, all hoses, Inducer Fan and housing, drained and cleaned the condenser trap, replaced the Condensate Pump and it's still shuts down. I think all that's left is the Gas Valve and Circuit board. How can I check now what's the problem? I don't want to pay for more items and they are not faulty. I'm getting very frustrated.
 
1 - 9 of 9 Posts
Top