DIY Home Improvement Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All,

I have a Lennox 80MGF3/4-100A-1 with a White-Rodgers 36E36-278 Gas Valve.

The furnace has been frequently going into WatchGuard mode since the burners fail to ignite. I cleaned the flame sensor and it functioned normally for a few weeks then started having the same issue. I would turn the furnace off/on repeatedly until it finally ignited.

During recent troubleshooting I was testing connections and moved the wire plugged into the C2 terminal on the gas valve. The burners immediately ignited and everything functioned normally for another week. The next time it failed to ignite, I simply moved the connector slightly and it worked for days again. I cleaned the contacts and confirmed a good connection.

It failed again today. I noticed that moving the connector slightly will either turn on or off the gas flow.

Is it the connection causing the issue or am I sending a signal when I move the wire into a dead spot that temporarily resets something and allows the furnace to run for awhile?

What are the chances that it's a loose connection in the terminal block itself?

I'm going to cut the wire back and attach a new spade connector to see if that is a fix but I'm looking for some advise on whether there is a known issue and I should be getting some parts on the way before I'm left stranded without heat.



Thanks,
 

·
Hvac Pro
Joined
·
23,627 Posts
I would put a new spade connector on but it is VERY very rare that you get a poor connection on a gas valve.

I suspect that whatever it is connected on inside the valve is breaking and faulty. basically you are likely going to need a new gas valve.

That furnace is about 20 yrs old and my Uncle has one and I am a Lennox tech.

You can remove that wire and put a volt meter on it and the M terminal if it has one. C is common and you should get 24 volts when the furnace fires up between M and C. If it is lower than 23 volts you may have a problem with the main circuit board or transformer.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi Yuri,

Thanks for the reply and the tips. I put my multi-meter on M1, the wire and C2 on the terminal but it didn't show any voltage even when the furnace called for heat.

I cut back the wire and put on the new connector and was surprised how loose the old one was compared to the new. The furnace has been working and firing up when it gets the demand. This is not unusual since it has worked for days after fiddling with the connection.

I'll update the forum in a week or if it fails again which ever comes first.

Here's hoping...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
It appears the problem is in the terminal. I replaced the spade connector and cleaned the terminal and plugged it all the way in. It lasted a day. As I was pulling the connector off the terminal the flames came on. I left the spade only half way onto the terminal. The furnace has been functioning normally since.

Probably not a loose solder or connection. My best guess is corrosion on the terminal. I'll leave it as long as it's functioning in the cold weather and see what I can do in the summer.

Thanks for the tips.
 

·
Hvac Pro
Joined
·
23,627 Posts
I don't know if you have replaced any parts on that furnace but it can be very expensive to repair.

Unlike the US it is very difficult or next to impossible to get Lennox parts online and you may end up paying a Lennox dealer.

If you have a Heatcraft circuit board it is obsolete and you need a newer Honeywell conversion board and it is quite expensive.

The inducer fan/exhaust fan for the smoke is expensive to replace and you have to remove the entire collector box it sits on.

Point is you may want to start budgeting for a new furnace as that one is going to need some expensive repairs due to it's age.

I would not mess around trying to fix that gas valve and get left in the middle of next Winter with a major repair.

It is repairable but not worth it unless you plan to move in the next year.
 
1 - 5 of 5 Posts
Top