DIY Home Improvement Forum banner

Kenmore Elite Ice Maker Wiring Harness Connection

2208 Views 13 Replies 2 Participants Last post by  bob22
3
Hello Everybody
Hoping someone out there has a solution to my puzzle concerning my Kenmore/Whirlpool Elite ice maker issue.
I’m trying to remove the ice maker completely and install the new one. However I cannot figure out how the wiring harness plug is disconnected. As shown in photo, the plug is behind a plastic cover. That cover DOESN’T want to come off to allow me to get to the plug connector. I’ve tried squeezing it, rotating it, pulling it, etc. but it won’t budge even though it moves loosely in place. I see no tabs or any other locking mechanism.
I’ve been all over the web looking for a video or instructions but all of them show a different location where ice maker is installed. Thus ice maker is in the door and not mounted in the freezer compartment. The freezer compartment would be an easy 15 minute job since there isn’t anything covering the connector but mine isn’t like that.
The replacement ice maker understandably uses the main plug harness end to connect everything. If I used the other end of the harness then I would have to swap out a few parts from the old ice maker which defeats the purpose of getting a new one.
Hopefully someone out there has experience with this type of installation and can tell me what I need to do to remove the cover over the plug connection.
Thanks
Gary
I’ll post photos ASAP since I’m on my phone and currently don’t have ability to add photos here now.

Attachments

See less See more
1 - 6 of 14 Posts
Is the circled part (the white cone shaped thing) the bit you want to remove?


I'm not clear as to why. The wiring harness goes back into that panel and may be embedded in expanding foam.

What is the benefit of not plugging the new part into the established plug?
See less See more
Doesn't the new one plug into the red circled bit here after the old one is unplugged?
See less See more
I’d take the chance that the simple path will work. Last time I did this I just unplugged the old thing and plugged in the new and it worked fine.
Sorry it didn't go as desired. I'm out of any useful advice.
Good luck!
Thanks for the update. It is a shame that an obvious weak point in the design wasn't addressed with a better idea but I guess this is part of "designed obsolescence".
1 - 6 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top