DIY Home Improvement Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
HI, I have a Day & Night 350MAV048100ACKA furnace that is on the blink.
It does nothing when I run through the test cycle and then flashes an 11. The inducer motor has been making funny noises for the last week or so every time it started up. When I start the test cycle, the inducer motor hums a little but won't turn the fan. Do you think it is a bad inducer motor, or could it be something else??? :(
 

·
Hvac Pro
Joined
·
23,688 Posts
Sometimes the impeller fan hits the housing inside and breaks and it sounds like you need a whole new fan unit. I have replaced lots of them. They get off balance and break, not uncommon. If it is a mid efficiency furnace with a metal pipe to the chimney, remove it at the top of the furnace and look for a dead bird inside the fan, no joke, it happens.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks, Yuri

Thanks for the quick reply. It's called a "Plus 90" furnace with a plastic pipe to the outside. I'll pull it off to see if there is something in the inducer fan cage. - Jim
 

·
Hvac Pro
Joined
·
23,688 Posts
Not an easy unit to remove and reinstall. Need red rtv silicone to seal it back up and it is VERY easy to pinch the vacuum hoses and break the silly accordian drain hoses. You need a whole inducer fan, does not come as seperate motor and fan.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Good to know!

That's good to know! I'll have to drop over to the wholesaler tomorrow to get some red silicon. By the way, I love your picture! It reminds me of our Chairman of the Board!
 
1 - 6 of 6 Posts
Top