DIY Home Improvement Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey everyone,

I stumbled onto this forum because of a member that posted a story about his TRANE XR90 furnace, and he had an issue LITERALLY IDENTICAL to the issue I am having. I so badly want to get in contact with him to find out if he fixed it, or what the problem was. However, I have no idea how to do that. I can't reply to the thread because its too old, and for some reason I don't know how to private message him. I so badly want to fix my furnace! haha

COLD IN OHIO!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
I am trying to add the link to the original post, so people can realize what I am referencing. But it is saying I need 1 post to post links. Here is my 2nd post. I hope this now allows me to post a link? haha
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Trane XR90 Igniting/Pressure switch issue?

As I posted in my welcome post, I have been having issues with my furnace on and off for months now. I have the EXACT issue another user described in another thread (that I will post below), and he has the same furnace as me.

I have a furnace that will sometimes produce a pressure switch error, sometimes I don't get that error, sometimes the furnace will get the call for heat, it will go through the process, the ignitor will glow, and then the furnace will try to ignite but won't. It will try, it makes 3 attempts or so, and then it will go into lockout for the 2-3 hours blowing cold air. I can get the furnace to fire 100% of the time if I remove the tube coming from my differential pressure switch (the right side) which is the tubing that reads the vacuum from the intake I believe. The left tube goes to the heat exchanger?

Like the original poster mentions as well, if its cold outside I hardly have ANY issues. If its cold, but more in the 32-50 range and its wet and rainy outside, this is when I have all the issues. I have had 4 techs out now trying to solve this and every tech tells me something different. One is afraid its a heat exchanger issue (but never ran any combustion tests). One thinks its the burners and the ignitor. Now the guy that I just had out 25 minutes ago thinks it could just be the pressure switch. He read the vacuum and got 1.35 on the one side, and .16 on the other. I guess my pressure switch needs to be above 1.15 to fire, so it should fire with that vacuum? I am still concerned something else is causing the issue and that is why it will work sometimes and not work other times.

I have already paid to have my exhaust and intake venting moved because I thought that could have been the issue, but that never solved it. I have no idea what to do.

Anyways, here is the link to the original post. If you want to read it, the member (dkenne) posts sum up the issue I am having. It is LITERALLY identical.

https://www.diychatroom.com/f17/trane-xr90-pressure-switch-error-help-diagnosing-590793/#post5270689
 

·
Registered
Joined
·
2,740 Posts
You'll get more views and potential help by posting this in the HVAC section.
Welcome to the forum.
 
1 - 7 of 7 Posts
Top