DIY Home Improvement Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone! I am new here and am really excited that I found you guys (and Ladies!). I have an ST700 Wagner airless sprayer that is about 30 years old. It worked fine until I tried to clean it this last fall. Now it is not working properly. When I turn it on it pressures up fine. after I pull the trigger and expend the pressure the machine will not pressure up. if I turn my knob to flush the machine bubbles come out of the paint can for a lil bit before it becomes a stream of water again. at this point if I turn the switch over to paint then the airless will pressure up fine. after pulling the trigger the scenario starts all over again.....Can anyone tell me what I did wrong?!! thanks in advance!
 

·
Registered
Joined
·
505 Posts
Hi everyone! I am new here and am really excited that I found you guys (and Ladies!). I have an ST700 Wagner airless sprayer that is about 30 years old. It worked fine until I tried to clean it this last fall. Now it is not working properly. When I turn it on it pressures up fine. after I pull the trigger and expend the pressure the machine will not pressure up. if I turn my knob to flush the machine bubbles come out of the paint can for a lil bit before it becomes a stream of water again. at this point if I turn the switch over to paint then the airless will pressure up fine. after pulling the trigger the scenario starts all over again.....Can anyone tell me what I did wrong?!! thanks in advance!
um…the knob you turn to flush the machine…is that your prime valve? …if so, are you priming your pump before filling and pressurizing the line?
 
1 - 2 of 2 Posts
Top