DIY Home Improvement Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi there,

I recently installed a Honeywell Truesteam 6 gallon unit.

I wired using "CONFIGURATION 2 - using a humidistat separate from the thermostat" (I am using the H8908), however, I couldn't seem to find a "C" wire so I didn't wire it. I'm guessing that is my problem...

Everything else I did agrees with the wiring diagram for "CONFIGURATION 2"... but after I send the call for humidity (which I know the humidifier is receiving properly, as the "Humidifying" light starts to blink after I adjust the humidistat, just like the manual said it should) and then press the "GO" button on the Truesteam, the Service LED blinks 7 times. According to the manual, the issue is "HVAC power not present". Again, I am guessing this is because of the lack of a "C" wire...

So, I guess my question is, where is my "C" wire? I opened up my furnace (which is an A.A.C Lenox HW/HWC Series model 26HWC123A-2B "Magic-Pak" Thru-the-Wall Unit) and I can't seem to find one... and in fact I found a connector on the circuit board with a "C" pin labelled, and there is no wire connected to it! The following album has images of that circuit board, and the connector in question: http://imgur.com/a/lH9Cl

I do have the manual for the "Magic-Pak" which has 3 wiring digrams for that system (one for 208/230 Volt Single Phase, another for 208/230 Volt Single Phase w/Low Ambient Control and the third for 208/230 Volt Single Phase HW Series... not sure which of these three is the one for my unit, however, I can tell you that all three diagrams indicate what is shown in my images; there are "C" terminals on the circuit board, but nothing connected to them!)... if needed I could take pictures of those diagrams and upload as well.

Thanks in advance,
-Jamie
 

·
Administrator
Joined
·
42,396 Posts
Can probably get a pin from radio Shack to insert into the molex plug, and get your common from it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Can probably get a pin from radio Shack to insert into the molex plug, and get your common from it.
I checked with a multimeter at that molex plug between C and R, and there was not 24V present.

So, I just tried running a wire from the ground screw which simply attaches to the frame of the A/C unit itself, and already has a couple of wires connected to it, and now everything works!

Thanks for the reply!
 

·
Registered
Joined
·
6 Posts
The class action law firm Halunen & Associates is investigating Honeywell Humidifiers for a possible defective product lawsuit involving TrueSTEAM humidifiers models HM506, HM509 and HM512. These models show signs of a possible defect in the heating coils and other component parts. If you have experienced any of these problems, you can share your concerns with the firm at http://consumer.halunenlaw.com/contact-us/ or call (612) 605-4098. [Advertising Material]
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top