DIY Home Improvement Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
Yesterday while cutting my grass with the lawnmower height adjustment at its lowest setting, I noticed that the blades don't come to an instant stop when I release the operating bar. It's like down whirling sound. Any ideas on the fix?
Thx.


Sent from my SAMSUNG-SM-N920A using Tapatalk
 

· Registered
Joined
·
75 Posts
Discussion Starter · #5 ·
Yup. Usually a motor brake not working is a sign the brushes need to be replaced.
Disappointed if it's the brushes. Owned this lawnmower for only three years. Am trying to make a warranty claim though I find it very difficult in contact greenworks.
Yesterday while cutting my grass with the lawnmower height adjustment at its lowest setting, I noticed that the blades don't come to an instant stop when I release the operating bar. It's like down whirling sound. Any ideas on the fix?
Thx.


Sent from my SAMSUNG-SM-N920A using Tapatalk

Sent from my SAMSUNG-SM-N920A using Tapatalk
 

· Registered
Joined
·
75 Posts
Discussion Starter · #6 ·
Finally got a hold of someone from Greenworks. Was told that it is a resistor gone bad which needs replacement. Will be getting a new resistor and I will see if it solves the problem after I recieve this item in the mail and install it.

Sent from my SAMSUNG-SM-N920A using Tapatalk
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top