DIY Home Improvement Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
So I have a 2016 furnace with a E2 error code that has intermittently problems. I changed the pressure switch and it seemed to work for a while but then within 24 hours is doing the same thing, inducer kicks on but no flame. If I reset the pressure switch, blow air into tube starts working again. Thermostat will call for heat but in some cases furnace will not even start. I am at the end of my rope here, I had a tech out and paid for the visit, he came back a second time and while he was here everything was working fine. A few hours later, same issue. GMVC961005CNAA is the furnace, this is a dual stage furnace currently I use a Sensi smart thermostat. I also tried a new thermostat without any luck. What else can I do to fix this issue?
 

·
Registered
Joined
·
13,517 Posts
Make sure the combustion air intake and exhaust are clear outside.

Check the condensate lines and trap for blockages. Water backing up can reduce flow and cause the pressure switch to not make.

Check the pressure switch tubes for blockages.



If nothing is obviously wrong, you'll have to get a manometer to check the draft.
 

·
Registered
Joined
·
6,493 Posts
Pressure switch is likely doing it’s job.
Tech should have checked draft while on site.
As said above you’ll have to check for blockages.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
I visually checked the exhaust and intake outside the house to make sure they are not obstructed and could not find anything. Then I called the maintenance tech and he diagnosed the problem as a faulty low pressure switch, did not have one in stock, too late 11 pm to get one, so he bypassed it for the night in order to get heat. The furnace worked but never kicked on right away when the thermostat would call for heat. Next day I found a new OEM switch and replaced it myself. Furnace started working fine, I had the tech come out just to make sure everything was good and later in the evening I had the initial problem again. I opened the furnace, saw the code, I checked the manual and again low pressure switch. This time is a brand new one. I took the rubber tube off and blew a little air into the switch, felt like it was stuck. Started the furnace again, working good since yesterday 11 pm. This is a two stage furnace and also setup for high fire, I think the code mentions something about that. When the tech was out here last time he was testing the high fire on the furnace.
I am not a HVAC professional but I understand tech and learn quickly. Obviously, I do not have the tools but I appreciate all the advice you guys got me so far. I will contact the tech and suggest what you guys mentioned in the previous posts. Thank y
 

·
Registered
Joined
·
6,493 Posts
Never ever bypass a safety control.
If that was the guys fix for the night he has no idea what he’s doing. That’s extremely dangerous and could have easily started a fire.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
Yes, I haven't closed an eye Friday night because I did not feel safe.

So the furnace is been working fine for almost 12 hours then again did not start when the thermostat called for heat. I opened the furnace and blew into that tube, started right away.
So maybe to explain this better, this furnace has 3 pressure sensors, low fire, high fire and another one that I was told I have to replace and I did. This is the sensor I keep resetting. The tech called me back this morning and said it is almost certain the low fire pressure sensor because the intake is clear and there was no water when I unplugged this tube. Another sensor? I do not mind replacing bad parts but I have a feeling he is just guessing now. How can I tell if the drain tubes are re clear of debris?
 

·
Registered
Joined
·
6,493 Posts
If this is the guy that bypassed the pressure switch, he has no idea what he’s doing. Don’t call him anymore as he’s literally going to hurt someone doing such (lack of) quality of work.
Blowing or sucking on the switches can damage the bellows.
Check draft with a manometer.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
I just asked the tech if we should check the draft, this is his response. To me it makes sense what he says but again, I am not a HVAC guy.


Yes we can def hook up a menomiter and see what the draft is. The low fire pressure switch is def the culprit. The door pressure switch is wired in series with the gas valve and the low fire is in series with the safety's switches. Having two switches fail is quit common. Replacing the low fire pressure switch will solve the issue. The inducer is not the issue. If the inducer was failing the pressure switch you replaced would not even close. But for the fact that the highest fire pressure switch is closing tells me there is more than enough draft to close the low fire switch.
 

·
Registered
Joined
·
6,493 Posts
Again, you should never use anyone that jumps safety’s out and leaves them. Even if it’s overnight.
We use meters to diagnose issues.
You have a parts changer that will charge you to keep changing things until he stumbles across the issue.
If the low fire switch was the issue, why didn’t he change it previously?
 

·
Registered
Joined
·
13,517 Posts
the inducer runs at a different speed on low so there's no guaranty it's the low fire pressure switch.
 

·
Hvac Pro
Joined
·
23,688 Posts
What exactly do you mean by having to reset a pressure switch?

They have no manual reset unlike some high temp limit controls.

Is it the door pressure switch you are working with?

You should never suck or blow into or on a pressure switch as the bellows inside could get damaged.

The proper procedure is to put a manometer inline with them.

Take the hose off of it and where it enters the burner box (NOT the switch itself) push a drill bit thru that orifice as sometimes they get scale build up. NOT the switch as some posters have done and damaged them.

If it is the door pressure switch then maybe the door is not sealing properly. It is there to prevent people running the furnace with the door off.

Post a pic of the switches.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
Thanks for your reply. It is not the door sensor. I am attaching pics. The sensor to the right is the one that I replaced, the group of 2 sensors I have not replaced. Following your direction I unplugged the tube from the furnace and slowly ran a small drill bit. I encountered a little bit of resistence and the bit came out wet. Not sure if this is normal. There was no water dripping out.
I meant reset the sensor by unplugging the hose and gently blowing air, I was told I can do that to get it unstuck. Live and learn, again thanks for advising against it.
 

Attachments

·
Registered
Joined
·
15 Posts
Discussion Starter · #14 ·
It was coming from that black tank in the back, not from the switch. I unplugged the drain tubes and checked, they are not clogged. I will try to get the switches this week, if the problem continues I will have a set of spare switches.
 

·
Registered
Joined
·
6,493 Posts
NO!!!!
DO NOT just start replacing random parts. It can lead to a pointless endeavor that ends with you out money and still stuck with broken equipment.
Everything there can be checked and diagnosed.
What tank do you speak of? Inducer? Collector plate? Exhaust?
 

·
Registered
Joined
·
6,493 Posts
That’s the collector plate, or collector box.
Shouldn’t have water sitting there. Sounds like you may have a clogged drain.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #18 ·
I took the hose at the bottom of that plate off, and there was no water coming out. I flashed a light into that hole could not see a clog and I gently pushed a wire inside. How else can I check without specialty tools?
 

·
Registered
Joined
·
6,493 Posts
Take all the hoses off and blow everything out. Make sure there’s no water laying anywhere. Clean the nipples on the pressure switches.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #20 ·
Ok, I will do exactly as you say and test tonight and post an update. Thank you everybody for advising me on this issue.
 
1 - 20 of 34 Posts
Top