DIY Home Improvement Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I just installed a new nat gas goodman furnace and it operated fine for a few weeks then it shut down showing a 10flash on board, no 10 flash in manual! I did finally check fuse and it was blown, replaced and everything is fine now. very odd as board should be dead if fuse was blown?
 

·
Hvac Pro
Joined
·
23,688 Posts
The board may have a code for a blown fuse or lack of 24 volts. Most do.

There should be a sticker on the inside of one of the doors or the code is in the wiring diagram on those doors.
 

·
Registered
Joined
·
43 Posts
I just installed a new nat gas goodman furnace and it operated fine for a few weeks then it shut down showing a 10flash on board, no 10 flash in manual! I did finally check fuse and it was blown, replaced and everything is fine now. very odd as board should be dead if fuse was blown?
Check new literature for your model off the goodman site, updates flash codes all the way up to 12 flashes. Would it be the GMES series ?

Sent from my SM-J337A using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
Thanks, even codes on blower door only go to 9...I looked on their website and couldn't find that info either, I scratched my head awhile before checking fuse! older furnaces the board was dead when fuse is blown?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top