DIY Home Improvement Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a new home and recieved a Honeywell IAQ (YTH9421C1002) from a family member who works at Honeywell. The furnace installer did not know how to install the IAQ with the furnace so put his own thermostat on. The Gibson(Nordyne) furnace is a SC92 and has the following connections:
R
C
Y
G
W

the AC is hooked up to C & Y.

I am able to get the furnace to run, but not the humidifer which only needs a 24v red wire/white wire to turn on the solenoid valve. I don't want to post what I wired to skew any answers.
Thanks in advance
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
yes there is an outdoor sensor, and the humidifer doesn't have a transformer, unless you use the humidistat that comes with it, but I want to use the Honeywell stat instead.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
The furnace kicked on(which is good considering it was -2F this morning). I can't tell about the humidifer right now, but I'll update on that. Thanks for your help!!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
The humidifer doesn't seem to be working. I have one of the solenoid wires to C on the module, and the other to hum2, and hum1 jumped to RH. I may check the valve, by wiring 20v straight into it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top