DIY Home Improvement Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
This summer I had flooding in my basement. The furnace was damaged. The inducer fan and control board were replaced. It worked fine for several months.

It recently stopped working again. The error code is 3 flashing lights indicating pressure switch stuck open. When disconnecting the pressure switch hoses, water drained out. I removed the pressure switch and drained it. I also removed the inducer fan to check for problems.

While the pressure switch and inducer were removed, I took them to my father's house where he has better electrical tools. We were able to start and run the inducer by powering it directly. The pressure switch appears to be working properly.

I reassembled the parts, and no luck. I can get the error message to change from stuck open to stuck closed by applying suction. The inducer will still not start. I am unable to check if power is being sent to the inducer, but since I know the fan works, I am assuming it is not.

I've decided it must be the relay in the control board, but the entire board was recently replaced. I suppose it is still possible. I keep wanting to return to the pressure switch, since I know it had water in it... but I am told that the inducer should still fire first.

Can a bad pressure switch prevent the inducer from firing, or am I just getting that code because the inducer won't start?

I am new to the forum. Any advice would be appreciated. Thank you in advance.
 

·
Hvac Pro
Joined
·
23,688 Posts
The inducer induces a draft thru the furnace heat exchanger and creates suction on the pressure switch to prove it is running. No inducer, no suction.

Was the board brand new in a sealed pkg or one bought from E-Bay and possibly used. Sounds like a bad one anyway.
 

·
Registered
Joined
·
13,981 Posts
If the inducer isn't spinning up at all, then the pressure switch won't make. With the gas shut off, take the inducer back off, but still wired, and see if it spins up. If the inducer wheel is touching anything, or sitting in water, it won't start, as they don't have the torque. Also make sure all connections are tight, both from the board, and back to neutral.

It would help greatly if you can get your hands on a multimeter and check for power at the control board output.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top