DIY Home Improvement Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all, I have one of these older furnaces (from the mid 90s). It has been running fine for the past. Just this past spring, we noticed that it would heat up nicely when temperature outside is mild. When the temp get colder, even though we set the thermostat high, it is not heating.

anyone have any idea to this?

last year we have a tech came in for inspection, everything was working fine and he was pretty much just all about selling me a brand new furnace/AC and water boiler.

i dont really want to replace the unit as we have potential tear down in the next year or two.

thank you in advance for your input. :smile:
 

Attachments

·
Registered
Joined
·
5,870 Posts
We’d need some diagnostics to even begin to suggest repairs.
Is the unit firing but not heating? Is it short cycling? Is it failing on an error?
Make and model of the furnace?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for your reply.
I dont have a specific model number buts its a lennox unit.

In colder times, the machine seems to try to turn itself on but fails. So it never get fired up. It would do that every half an hr or so until i turn it off.

However in warmer times, it would fire up fine and work normally.

any idea to this? just seems to be very strange to me.
 

·
Registered
Joined
·
5,870 Posts
Check the gas pressure and clean the burner.
I’d have a non-sales oriented company come do a pm and cleaning.
 
1 - 4 of 4 Posts
Top