DIY Home Improvement Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
Hi guys, I have a Fujitsu Halcyon DC inverter in my basement that is not blowing hot air. The unit turns on and just blows cool/room temperature air despite it being on the heat setting.

Any suggestions on what to do? I did do a google search, but my filter is only lightly dirty (and wouldn't get in the way of blowing hot air anyways). I looked at the unit from the outside and other than looking a little rough from exposure to the elements, it looks fine.

What can I do at this point before bringing (and paying) someone to look at it?

Thank you for the help.
 

·
Registered
Joined
·
6,417 Posts
Is the compressor running?
If so check refrigerant charge. If there’s pressure in the system the charge should be pulled and weighed.
 

·
Registered
Joined
·
6,417 Posts
It’s in the outdoor unit.
Although if it were not running when it should you’d likely get an error code showing on the system, and it would not run.
 

·
Registered
Joined
·
129 Posts
Discussion Starter #5
Oh then yes, the compressor is running. The system turns on and blows air. The issue is that the air is not coming out warm. It just blows out cool air when I want to heat up the room.

I don't know how to check the refrigerant charge.
 

·
Registered
Joined
·
6,417 Posts
It’s likely time for a service call then. Have the charge checked. If it’s low the leak will have to be found and fixed.
 

·
Registered
Joined
·
129 Posts
Discussion Starter #7
I think that's what I'm going to have to do. When I have my HVAC system serviced in a couple of months, I'll ask them to look at the Fujitsu unit. Thank you for your time and help.
 

·
Registered
Joined
·
129 Posts
Discussion Starter #9
Noted. It's never turned on anyways. I have some family visiting and they're sleeping in the basement so that's why I turned it on to see if the heat worked. I will be sure it's left off. Thanks again.
 
1 - 9 of 9 Posts
Top