DIY Home Improvement Forum banner

Ducane Gas Furance with Honeywell Ingnition Not Firing...

8001 Views 33 Replies 4 Participants Last post by  BDPNA
My Ducane gas furnace is refusing to light, and it's getting COLD in here! Would love to call a tech but all are on emergency-only service for the holidays and I just can't afford that right now. Any suggestions on getting it to light, even just once would be great!

Some background - 13 year old natural gas furnace, brand new with house. A couple months ago I noticed that the pilot was kicking on and I heard flame/heat for about 2-3 seconds, then I'd hear another noticeable click and it would shut off. Main circulation fan would never start. After disconnecting some cables and troubleshooting, it just sort of started working again. Fast forward to today...

The unit turns on but only the small fan in the middle, and I don't hear the honeywell ignition unit (upper center in photo) clicking or trying to fire at all now.

Last night, a friend advised that I look in the exhaust hose trap from that smaller black fan inside the unit (that t-junction down on the lower right), sure enough, sucker was full of water! I siphoned that all out of there and re-connected but still, no luck -- After that last night I did hear it attempt to fire up once again (the pilot) but now, when I turn the power back on, the inner fan runs, but I don't even hear the pilot attempting to light/click at all anymore.

Anything safe I can try to get some heat going for Christmas? I'd be most grateful.

Oh another question as well - Am I potentially doing harm to myself or the system to leave it running without the pilot lighting and heat flowing? Any gas risk by this happening? I don't smell gas but I assume it's flowing and without it being lit I'm not sure about the safety risk.

I'm not sure if this would have had any effect on why the igniter isn't even trying to start anymore, but a couple times I got lazy when I wanted to unplug a few things and shut off the unit using the red emergency shut off switch on the wall next to the unit. I've got it back on now, and am using the breaker to shut off power to the unit now when I am messing with it, but is it possible I have to reset something elsewhere since I had used that red emergency shutoff switch? Or a particular order I need to power/switch stuff back on? It's peculiar because yesterday, the Honeywell auto-ignite was at least trying to fire from the sound of it, today, it's not even trying at all.

Any help during this holiday weekend would be most appreciated!!!

See less See more
21 - 34 of 34 Posts
I actually managed to take a video of it, just on the off chance it might throw up a light bulb of what it might be so I can get the heat running today (VERY cold, we of course had snow last night).

If anyone has any ideas, though to me it's probably out of my hands and in need of a part and no new information.

This is a video taken via the view window. You'll hear the gas come on for about 3 seconds and then will hear the noise it makes as it shuts off.

This is probably not any new info, just confirming what you all already knew, but this is what it does. Sometimes it takes a couple minutes to do this after I fire it up, but I typically don't leave it on much longer after it fails, no idea if it retries.
Looks like you need a new gas valve. That one (honeywell smart valve) has the electronics for the hot surface ignitor built in. Also the inducer assembly is sounding rough,might need a new one of those soon.
Amazed you can hear all that in my terrible video. Thanks for the reply. I'm hoping that a tech can make it out tomorrow after the holidays are over. You really start to miss heat after 5 days!

At least it looks like there's nothing I could have done to fix it - What bugs me is that I can see the darn thing light and flame flowing in there for a few seconds, if only it wasn't kicking itself off! But I have to keep telling myself it's doing that for safety reasons.

I wanted to share more information to see if anyone can advise if this is now a fix I can do on my own, also in the hopes of helping others. A tech was out and disconnected the hose from the switch at the point marked with the blue arrow. As soon as he did, the gas turned back on and the house fan, all was well.

Reconnecting that hose kept things running so he thought it was going to stay working, but was still unsure if the part circled in yellow (pressure switch?) needs to be replaced. Part number on it is PPS10034-2278 but I can't seem to find one online so I imagine it's been replaced with a different part/number?

Sure enough, overnight, it stopped working again. The hose by the way runs into a plate marked with the orange arrow.

If I remove the hose at the spot marked in the blue arrow, what risks do I have in letting the heat run until the tech can come back out after the New Year holiday? Safe? Not safe? The heat turns on instantly when I disconnect that hose.

Also, if this is indeed the part marked in the yellow box, is that something I can just order and swap out myself? It looks like just two wires and a couple screws going into it.

Thanks all!
See less See more
DO NOT disconnect that hose. The pressure switch is a critical safety device for the furnace. I proves there is enough draft for the burner to fire safely and enough air for safe combustion. Bypass that and you will permamently damage the heat exchanger or worse. He should be checking it with a manometer and it sounds like you need a more experienced tech.

Thanks for your reply, I appreciate it. When I disconnect the hose, after the induction fan is on, it obviously fires up the burner and the fan, I then immediately plug the hose back onto the barb, and fan keeps running / gas flowing until it reaches set temperature. When the tech was here, he showed me that when he blocked the hose (pinched it shut), the gas shut right off. However, the fact that the gas does NOT shut right off when I connect the hose back to the pressure switch, does that tell us anything?

In other words, I can get heat flowing in the house, once the induction fan starts, by removing that hose, waiting 20 seconds for the gas to light and blower fan to start, then reconnecting the hose.

I have no problem paying for this to be fixed, but it sounds like what he is going to bring is a new pressure switch, as he said he looked at it and the indicator inside it didn't look like it was positioned right or something...If you think installing a new pressure switch isn't the answer I'd like to cancel it before he brings it out. Or even find a new tech.
See less See more
I just listened to the system turn on, gas fire up, and the blower fan, from where I am sitting, with no intervention on my part at all. So that time, it worked, but later in the day, it might not.

Is it possible that this is actually the switch doing its job and a low pressure situation? I have a feeling the tech is going to come back, and replace a part that doesn't need replacing, but I'm right back to where I was before...But out the cost of part and labor for something I don't even need.

Are there any checks I can do as a novice to check pressure? I don't want this guy (or anyone for that matter) to replace the pressure switch, or the smart valve (as someone had also suggested), if neither of those parts are the problem. I feel like I'll get stuck with a huge bill for parts that I didn't even need switched out to fix the problem.
Welcome to my world. Troubleshooting is not an exact science or that easy and we cannot do it over the net all the time. If the switch has a rating on it like .48"WC then he should hook up a manometer to that hose and see if the pressure is OK. I have not seen that furnace for a few yrs and those Ducanes are a bit different in what they monitor the pressure on and how. The newer ones have one switch that does 3 functions. You really should find or get a troubleshooting manual to describe what those switches do to help him. It may be a bad switch and problem solved. Otherwise you really need a troubleshooting chart and it is in the install manual. The switch checks for venting obstructions, drainage issues (too slow), problems with draft thru the heat exchanger etc. I would have to be there to help more. See if you can find the troubleshooting info and post it here.
Did you get your problem resolved? Pex SUpply is really good for parts.
Back from a New Years trip, and things seem to be working well again, though the night we left, we couldn't get the thing to light or stay lit no matter what we tried. We had the repair place set to come back again tomorrow, but now it seems that things are fully operational again, even on the few random checks from neighbors, things were lighting up. Guess I gotta strangely hope that things either start acting up again before tomorrow, or risk having it kick out on the weekend. I'm wondering if having my furnace in "away" mode and not needing to kick on quite so much was what allowed it to operate normally.

We'll see what happens, thanks for the line on parts, which I'll keep handy, though it sounds like a manometer hooked up will answer a lot of questions, next time it's NOT staying lit, so let's hope the repairman has one and is willing to hook it up the next time it's acting up.
Yuri, You need to write a book! I would buy the first Hard copy straight away!
Hope the repairman has one, and is willing to hook it up? Your kidding, right? :huh:

What is he, the HVAC Nazi?
Haha, true true. I just try and not offend repair people as it's their line of work, I'm no HVAC expert so I don't want to tell them how to do their job either. Funny enough, today I didn't see him try a manometer at all, he simply replaced both switches with new ones (one of them looks like a different model altogether) and so far, knock on wood, things are running perfectly. We'll see how it goes over the weekend though, it's worked this long before and then broken again. I did ask to keep all the old parts in case it didn't fix it, so they could be put back and the new parts returned.
Just following up - After replacing both pressure switches, no issues. Bad pressure switches seemed to be the problem oddly enough.
21 - 34 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.