DIY Home Improvement Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
So lastnight was doing dishes and noticed no hot water. Thought maybe out of oil but not. Checked and reset had tripped so I press reset and nothing!! No pump no motor Nada and its been -20° here!!! Luckily got a small Amish box heater keeping main rooms 65° but need a furnace.
So red light on on reset and nothing at all happens when reset pushed then after 30-45 seconds trips reset again
 

·
Administrator
Joined
·
42,396 Posts
Look for a red button on the motor itself. Push it to see if it resets. Will also need to reset safety control again after resetting motor.
 

·
Registered
Joined
·
1,104 Posts
So lastnight was doing dishes and noticed no hot water. Thought maybe out of oil but not. Checked and reset had tripped so I press reset and nothing!! No pump no motor Nada and its been -20° here!!! Luckily got a small Amish box heater keeping main rooms 65° but need a furnace.
So red light on on reset and nothing at all happens when reset pushed then after 30-45 seconds trips reset again
is this on just a water heater or boiler with coil? electric going to the burner? wall switch turned off by mistake?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
It is a furnace with baseboard and also does hot water as well. Wall switch is on green and red zone lights are on and red reset light is on but when reset is pressed nothing happens except the button popping again in 30-45 seconds
 

·
Registered
Joined
·
1,104 Posts
It is a furnace with baseboard and also does hot water as well. Wall switch is on green and red zone lights are on and red reset light is on but when reset is pressed nothing happens except the button popping again in 30-45 seconds
some of the newer controls have lockouts after you press them once or twice..I think if you turn off the power to the unit for a few minutes it resets the control, but you still need to find out why the burner wont stay running..
 

·
Administrator
Joined
·
42,396 Posts
Safety control may be worn out, and not sending voltage to the motor or ignition transformer. Its not an uncommon problem.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top