DIY Home Improvement Forum banner

bathroom sink pressure issue.

2823 Views 4 Replies 2 Participants Last post by  tgamblin
hello everyone. my fiance and i just bought a house about a year ago now. its an older home built in 1902 and even though it makes weird noises and isnt our dream home, its ours. anyways, when we bought the home the bathroom downstairs wasnt quite finished. it had been drywalled, the shower and the toilet were installed. we still needed to lay the tile flooring, finish the drywall, and hook up the sink. well we bought a pedastal sink because it was such a small bathroom it only made sense. i ran all the plumbing myself by tieing into a hot water line and cold water line that ran close to where i needed the lines. installed the faucet on the sink and it worked great. everything was ok in there for probably 6 months. this past winter when it got really cold out the pressure went WAY down in the bathroom and we lost all water in the kitchen. i figured that the pipes had frozen because they are the only lines that are in a spot that isnt insualated/heated under the house. so i got under the house into the crawl space, nothing busted so i said screw it and waited for a warmer day. well about 2 or 3 days later we had our regular water pressure back in the kitchen, but the bathroom was still just barely there. well, its still like that. im wondering if maybe something could have gotten broke in the faucet to stop the water from coming out at full pressure. is that possible? im really kinda lost/frustrated about this. any help would be greatly appreciated. thanks in advance.
1 - 2 of 5 Posts
Have you first tried removing and cleaning the aerator?
It screws into the end of the faucet Sometimes freezing pipes can break loose deposits in the pipe and they clog the aerator. Be sure to cover the sink drain with a rag so you don't drop any of the parts down the drain. With the aerator off turn on the faucet and see if you have pressure.
See less See more
1 - 2 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.