DIY Home Improvement Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,

About two weeks ago I came home to a freezing house (56 degrees). A little harsh when you're use to 78 degrees. I noticed that the furnace was running but only blowing out cold air since there was no flame. I then turned the furnace off and back on. The furnace turns on and within about 10 seconds you get a flame but after about 5 more seconds the flame is gone. I tried this several more times until it actually stayed burning. Sometimes it will stay lit right away, sometimes it takes a few trys on its own, but occasionally it will not light at all and blow cold air until you shut it off. This seems to happen 1-2 times a day.

I have no knowledge or experience with furnaces (besides changing the filter), but DO NOT want to resort to hiring somebody. If anybody can help I would greatly appreciate it.

Furnace: American Standard Freedom 78
Model: TXC025C4HPB1
Does not have a LED light
Do not have a manual

Thanks,
Kevin
 

·
Hvac Pro
Joined
·
22,783 Posts
If it has a flame sensor clean it with emory paper. Should sit in front of one of the burners and look like one of these:
 

Attachments

·
Registered
Joined
·
1 Posts
furnace

Did you ever get this problem fixed? I'm having that exact issue and i am clueless where to even start?
hi,

about two weeks ago i came home to a freezing house (56 degrees). A little harsh when you're use to 78 degrees. I noticed that the furnace was running but only blowing out cold air since there was no flame. I then turned the furnace off and back on. The furnace turns on and within about 10 seconds you get a flame but after about 5 more seconds the flame is gone. I tried this several more times until it actually stayed burning. Sometimes it will stay lit right away, sometimes it takes a few trys on its own, but occasionally it will not light at all and blow cold air until you shut it off. This seems to happen 1-2 times a day.

I have no knowledge or experience with furnaces (besides changing the filter), but do not want to resort to hiring somebody. If anybody can help i would greatly appreciate it.

Furnace: American standard freedom 78
model: Txc025c4hpb1
does not have a led light
do not have a manual

thanks,
kevin
 

·
Registered
Joined
·
2 Posts
HI i have an AMERICAN STANDARD Freedom 78 unit and the furnance is set correctly and blowing cold air all the time unless I turn the unit off. The led indicator is flashing fast (steady not stopping) red light. I hear the unit clicking but I don't see the pilot light burning or and the burners won't light. Thanks for any helpful information.
 

·
Registered
Joined
·
2 Posts
American Standard Freedom 78 furnace pilot light not lighting

I have an American Standard Freedom 78 Furnace blows cold air all the time and tries to light the pilot but just clicks. The thermostat is set correctly and is on the Auto setting. What is the most problem with my unit?
Thanks,
 
1 - 5 of 5 Posts
Top