DIY Home Improvement Forum banner

oil furnace

  1. HVAC
    :confused1: I am puzzled by my thermostat. It is a Honeywell FocusPRO TH6000 wi-fi. When it is set to primary heat (heat pump), it set the temperature just fine. When i set it to Emergency to use the oil furnace, it does not stop at the set temperature. It just keeps heating until I turn it back...
  2. HVAC
    We purchased a house about 3 months ago. It's a 1955 ranch-style - some bits are modern and some are 1955 original. While painting a while back, I removed the heating intake vent cover (I assume that's what it is - it's covered by magnetic panels at the moment), and saw the image below. I'm not...
  3. HVAC
    Hello everybody, this is my first post on the DIY forums. Sorry if it is a long one. My sister and I have been working on updating and remodeling our fathers house. The house is 768 sq ft on the main floor and is in Portland, OR. It is a single level house with a basement. It has a forced...
  4. HVAC
    I just moved from Ohio to New York and was surprised when I found that like everyone here uses heating oil. So my new house has a newer unit and it seems to be working just fine with one odd exception. I would like to know if it's normal. When the temp. drops the burner kicks in a burns for...
  5. HVAC
    We moved into our home about 5 years and have since replaced the oil furnace with a HE gas furnace. The furnace was fed from an oil tank in our basement with overhead copper lines. After it was removed, I discovered a pair of copper lines previously cut off at the concrete floor. I have since...
  6. HVAC
    Hi folks, I'm planning to upgrade my forced-air HVAC system in mid to end of summer with a full Heating and A/C system. The current system is an old oil fired Magic Chef unit with no AC on a basement tank. The current heating company (at time of purchase) came out and performed some...
  7. HVAC
    Hello, I have 10 year old Rheem oil furnace. My oil tank (I think it is 250 gallons) is 25% full. Two days back the furnace stopped blowing hot air. It looked like the blower in the furnace was working but the furnace was not ignited. So there was only cold air blowing from all the vents. I...
Top