Water Softener ??? - Plumbing - DIY Home Improvement | DIYChatroom
Advertisement


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread
Display Modes
Old 05-08-2016, 09:02 PM   #1
Newbie
 
Join Date: May 2016
Posts: 1
Rewards Points: 2
Default

Water softener ???


I am having problems with a Culligan Mark 89. I have already replaced the eductor and a rubber seal on the valve assembly. when going in to manual regeneration it will go into backwash and then refill but after that it does nothing. My dishes are still covered in calcium. I have also spent 3 hours on here reading and checking for other solutions. IE the float assembly the line has got suction. My question is would it be more which is the best route to go:

1. Call Culligan and see if they can fix this unit for less than 300.00

2. Purchase a new Culligan unit for 1800-2500. This is a lot of money.

3. Or go ahead and replace this whole system with a Fleck 5600 SXT system for around 700.00 installed.

Trying to make a wise decision i am still in sticker shock with the prices the Culling guy gave me for a new system and i want to make a good choice since the wife still wants a new front door and a remodel on a bathroom.

Any advise or path to follow would be greatly appreciated. Thanks David
IzzysAuto is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-09-2016, 12:46 AM   #2
Water Treatment
 
Akpsdvan's Avatar
 
Join Date: Mar 2010
Location: Alaska
Posts: 1,078
Rewards Points: 1,184
Default

Re: Water softener ???


Mark 89, First up is the backwash and then it moves to the brine draw and slow rinse(draw and slow rinse)are part of the same step in the cleaning cycle or the motor moves the upper and lower piston to the next step so that the draw can happen and then the slow rinse continues after the brine has been drawn out of the salt tank.
Now some thing that could be is the main piston has a seal or two that is bad and allowing a cross over with in the valve body and not allowing the proper brine draw if your not getting any.
The main piston could have a scratch and no matter of seals will cover that.
Either way I would go after a rebuild kit or see about moving the middle seals to the ends of the seal pack assembly and main piston and see how that goes.
Yes yours will need a replacement at some time, but lets try and get this one running for now.
Akpsdvan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Softener or Water Filter? vettegc Plumbing 2 04-24-2016 08:45 PM
Chasing Ghosts - Phantom Water Leak FrozenMeatballs Plumbing 7 10-29-2014 06:03 PM
Water Softeners rickglarson Plumbing 1 01-09-2012 04:10 PM
Solar hot water indatom123 Green Home Improvement 0 12-19-2010 12:01 AM
A blocked water line causing water to loose heat? Snav Plumbing 6 05-07-2010 02:18 PM




Top of Page | View New Posts