DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (https://www.diychatroom.com/)
-   Plumbing (https://www.diychatroom.com/f7/)
-   -   Water Quality Issue (https://www.diychatroom.com/f7/water-quality-issue-399530/)

dal-designs 05-23-2016 06:16 PM

Water Quality Issue
 
A little backstory:

I recently inherited the house that I grew up in, which was built in 1914, located in SE Victoria county, Texas. The house didn't have running water until the 1950s as far as I have been able to figure out, but my mother had a new water well drilled to 140' about six years ago (the old well casing had finally rusted through and collapsed).

I moved a new mobile home onto the property about three months ago to live in while the old house is being renovated. And I immediately noticed something odd: while the water in the old house is clean-smelling, the water in the mobile home has a sulfur smell to it.

Now, both properties are connected to the same well, the same pump, and the same tank. Neither has a water softener or filtration system. Why does the water in the mobile home smell like sulfur, then?

jmon 05-23-2016 06:47 PM

Re: Water Quality Issue
 
What kind of water heater is in the mobile home? Sometimes the water heater anode rod can be the culprit.

jmon 05-23-2016 07:23 PM

Re: Water Quality Issue
 
Well water is usually more alkali then regular municipality water when not filtered, etc., and can react with the water heater anode rod causing that sulfur smell especially when using hot water.

I think your issue lies with the mobile home somewhere. Just my opinion. You could have other issues going on.


All times are GMT -5. The time now is 07:20 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.