Kenmore Oven Not Working - Appliances - DIY Chatroom Home Improvement Forum
Advertisement


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Like Tree2Likes
  • 1 Post By BayouRunner
  • 1 Post By yuri
Reply
 
Thread Tools
Display Modes
Old 03-03-2018, 05:11 PM   #1
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Kenmore oven not working


Hi

I have a 14 yr old basic Kenmore oven that stopped working. Neither the broiler or main element work.

I have checked them and the broiler reads 21 ohms and the main element 19 ohms. I checked the temperature control ( reads the baking temp ) and it has continuity and reads 1.08 K ohms which is 1080 ohms.

There is no thermal fuse on the back like I see in some videos and I was not using self cleaning. The regular stove top elements work fine.

I get 120 volts to neutral on both elements and ground but no 240 volts across them which I suspect means the control board is not closing the circuit.

Does anyone have any ideas what it may be.

I will trade you furnace repair advice for stove advice.

Thanks

Yuri
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2018, 05:40 PM   #2
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


That's some good info. Helps a lot. How about a model number so I can see how it's wired
BayouRunner is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2018, 06:11 PM   #3
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


It is a C970-595084

I got brave and took the top part off and found the circuit board AND the thermal overload with a red reset button. Strange they put it way at top when most seem to have it at the back. It was not popped. I ohmed it and it is closed.

No burnt or loose wires or overheat marks on the board.

Thanks

Yuri
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2018, 06:12 PM   #4
Remodel and New Build GC
 
MTN REMODEL LLC's Avatar
 
Join Date: Sep 2010
Location: Colorado @ 7651'
Posts: 8,362
Rewards Points: 528
Default

Re: Kenmore oven not working


Yuri..... I am in no manner an appliance repair guy.... but I've fixed two stoves in my life, and they happen to be I think your likely problem.

On the board there re a set of relays, that basically put the 240 to your elements. They will be about the size shape of a dice (as in crap table ) or I guess a sugar cube.

The first was a bad solder joint on the board to the relay (I could see by closely inspecting (with my glasses on) and a local computer shop soldered it back for nothing really, but I gave him a $10 tip to get a beer.

The second one was also a bad relay, but I had to send the board off for repair... I think it was $60 plus postage...

In either case, alot better than 300-400 for new board.

Good luck...
__________________
Never stop learning (xcep fer speling en typeing)
MTN REMODEL LLC is offline   Reply With Quote
Old 03-03-2018, 06:26 PM   #5
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


Yeah I found the relay. Just like the relays they use in furnace circuit boards they last about 10 yrs. After building trillions of them they can make them last 10 yrs. Not sure if I want to take it off now but I may check into the solder joint issue. Most likely it is a sticking relay.

I dread the thought of a new board cost in Canadian dollars. Maybe I will buy a new stove when they go on sale and just use the top elements and my toaster oven for now. In the summer I never use the oven and just use a microwave or toaster oven. Too much heat load for the AC with a big oven.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 03-03-2018, 06:36 PM   #6
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


Turns out I donít have the access to Canadian model numbers. But anyway I believe I got this right. First see if you have 240 volts at P1 &P8 on control board. If you do then turn bake on measure at either p1 and p3 or p8 and p3. You should have 240 volts at one of those two terminals with the bake on. If you donít you have a bad board which I think you already have figured out. Part# 316418762. Verify that part number as I canít look them up my normal way


Sent from my iPhone using Tapatalk
BayouRunner is online now   Reply With Quote
Old 03-03-2018, 06:40 PM   #7
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


Actually I think I got it wrong. Looking at wrong board diagram. I would just try to follow the 240 volts through the control board


Sent from my iPhone using Tapatalk
BayouRunner is online now   Reply With Quote
Old 03-03-2018, 06:51 PM   #8
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


I got the wiring diagram on a piece of paper they stuffed in the elec area and can follow the wires to the pins and they have those numbers. I put it back together for now and will horse around with it later.

It was built in Toronto, Ontario so we must have different numbers.

Do any of the other parts usually fail like the temperature control? I would hate to buy a board and then that fails.

Thanks

Yuri
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 03-03-2018, 07:01 PM   #9
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


Yes they fail but they donít normally fail and not turn on at all. Usually the temperature is way out of range. Wanted to verify if the board was getting 240 because all the controls could still work but the oven not work if the board wasnít getting 240. Some boards only have 120 going in and out but I donít think thatís the case with yours. I think itís actually a Frigidaire product as well. Which we change a lot of boards on. I own an ac and appliance company. Although all my work is ac and I have a few guys that do the appliances but Iím pretty familiar with them as I order most parts and am reading service bulletins daily. I only get the problem ones lol


Sent from my iPhone using Tapatalk
BayouRunner is online now   Reply With Quote
Old 03-03-2018, 07:11 PM   #10
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


I can read schematics like a comic book and yeah it has 240 volts going in. The 2 elements join and go back to the board and L2 after going thru the board. Then there is L1 in. Pretty basic once I studied it.

I will do more troubleshooting on it but at first I was not sure how the front comes off. I did not want to break something and have no stove. Usually that happens to me when I do something out of my HVAC field.

Out of curiosity what is your wholesale cost for that board if you know. I can convert it to Can $$ and just want a rough reference point. If I phone our appliance guys I will get a retail thru your nose price I am sure.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 03-03-2018, 07:17 PM   #11
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


Temperature sensor should read about 1080 to 1090 ohms at room temp. Iím working with a different model number but I believe that should be correct. Good luck


Sent from my iPhone using Tapatalk
BayouRunner is online now   Reply With Quote
Old 03-03-2018, 07:20 PM   #12
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


Yeah I found some videos and they said 1100 but 1080 is close enough.

Thanks
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Old 03-03-2018, 08:17 PM   #13
Member
 
Join Date: Feb 2016
Posts: 2,346
Rewards Points: 534
Default

Re: Kenmore oven not working


I looked at one account and wholesale was $172. That's for one with a convection oven, I couldn't look up your correct part number though. You can pm me the correct one or post it the one on your board and I can get the correct price on one. Parts vary widely though. Some places I can get it cheaper or more expensive. No one supplier is really more inexpensive then the other. Getting ready to go frogging with a buddy of mine. He's bringing 4 of his grandsons. I think I am about to be entertained watching the young boys. Gonna be a good evening!
MTN REMODEL LLC likes this.
BayouRunner is online now   Reply With Quote
Old 03-04-2018, 08:32 AM   #14
Hvac Pro
 
yuri's Avatar
 
Join Date: Nov 2008
Location: Winnipeg, Canada
Posts: 21,639
Rewards Points: 1,410
Default

Re: Kenmore oven not working


Thanks for the info. I imagine it will be well over $200 Canadian and I may just buy a whole new range when Best Buy has a good sale. With my luck the temp control will go out of whack shortly after. Enjoy the kids. My nephews are great. One is 13 and he is very mechanically inclined. Is interested in robotics and is taking entry level courses for teens at our local Community college and the University. They made a crane out of syringes and water and aquarium air line tubing and levers so they learn about hydraulics. This one will be a Engineer.
BayouRunner likes this.
__________________
"Cut it twice and it is still too short".
yuri is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenmore Oven Non-Functional pistol22cal Appliances 3 12-09-2016 04:42 PM
kenmore duel fuel oven suddenly just isn't coming up to higher temperatures mgkutner Appliances 2 02-18-2015 12:45 PM
Oven on gas stove not working ... xtal_01 Appliances 3 10-23-2014 11:26 PM
Help fixing Kenmore oven jackpine Appliances 3 03-25-2013 10:43 PM
kenmore in freezer ice maker not working fullthrottle Electrical 2 07-02-2010 06:40 PM




Top of Page | View New Posts