Kenmore Gas Burner Won't Spark - Appliances - DIY Chatroom Home Improvement Forum
Advertisement


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools
Display Modes
Old 02-16-2015, 09:05 PM   #1
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default

Kenmore gas burner won't spark


. . . it's been a tough row, so far, my friends. . . tough getting the top up, since the burner bolts were all heat & food soldered in.

I tried replacing a spark igniter. Didn't work.

Here's the picture. I've got a Sears Kenmore gas stove with one top burner that didn't work. It didn't click. . . so I bought the igniter and put her in. This new one doesn't fire either.

SO. . . internetting around DIY-Land, I understand this could mean either the stove's spark module is kerblitzed or else the wiring harness isn't working.

HOW do I figure which of these two is the culprit here?




I did check to see if the faulty burner was getting any spark. I used a cheap electric tester and it flashed a micro-bit.

I'm just totally confused and can't tell which way is up on this one!

Any tips or thoughts here? I'm at the praying stage!
Siwash is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-20-2015, 06:01 PM   #2
Member
 
Join Date: Aug 2014
Posts: 241
Rewards Points: 455
Default


The igniter most likely has wires connected to it and the quick connect terminals on the wire(s) may be bad. Or the switch in that burner is bad. One of the two is bad. To check the switch, sap it with another burner that works. If that one faults then you have a bad switch in the gas adjuster/ igniter unit.
sparky90 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2015, 07:07 PM   #3
#1 HAWKEYE FAN
 
hardwareman's Avatar
 
Join Date: Oct 2010
Posts: 1,903
Rewards Points: 1,716
Default


check the spark module and the burner switch. Check module by doing a voltage test, find the wire that goes to that burner switch, remove wire and check for 110 volts from terminal on module to ground. To check switch just do a continuity check. But the first thing I would do is remove burner head and clean underneath it really good, it has to have good contact with stove top to spark.
__________________
................."I want a house that has gotten over all its troubles. I dont' want to spend the rest of life bringing up a young and inexperienced house"...........
hardwareman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2015, 09:40 PM   #4
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default


I 'll give it a good cleaning. I am getting a spark usually, but it jumps downward.

My big thing is getting the new igniter into the right relative position. I had to drill out the old one, which makes it tough to attach the new one.
Siwash is offline   Reply With Quote
Old 02-23-2015, 01:42 PM   #5
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default


I appreciate hearing other peoples thoughts on this.

I'm just not getting the spark to shoot right on the thing.
Siwash is offline   Reply With Quote
Old 02-23-2015, 06:51 PM   #6
#1 HAWKEYE FAN
 
hardwareman's Avatar
 
Join Date: Oct 2010
Posts: 1,903
Rewards Points: 1,716
Default


your not being very clear.First you say it won't spark, replaced ignitor didn't work, then you say your getting spark but jumps downward. You say you put in a new igniter but may not have it in correctly. I'm confused.
Obviusoly since your getting spark your module and switch are good. That leaves the igniter or your burner not as clean as it needs to be for spark to happen. Sometimes a picture is worth a thousand words.
__________________
................."I want a house that has gotten over all its troubles. I dont' want to spend the rest of life bringing up a young and inexperienced house"...........
hardwareman is offline   Reply With Quote
Old 02-24-2015, 12:53 PM   #7
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default


Sorry. I gave it all another go. There's a new igniter that will shoot sparks when (I'm guessing) there's about the right space for a gap. Sometimes it shoots downward, sometimes not at all, and sometimes just right.

The hassle I've got is that to get the old one out, I had to drill out the screw that holds in the igniter. I think---let me know what you think---this makes it tough to get the right distance between the new igniter and the burner.

I'm going to give this thing even more cleaning and will report back. What's been frustrating has been the baked-in screws.
Siwash is offline   Reply With Quote
Old 03-28-2015, 12:46 PM   #8
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default


I call my basement the "Center for Advanced Dad Technology."

I ain't giving up on this yet! I just received a new burner component---the one that holds the electric igniter.

My guess is that with the new component---and the right screw---that damn igniter will be positioned in JUST the right spot to make the right-size, right spark gap and make the spark we need here.

But the component doesn't have any threading in the screw holes!

Guy at the hardware store just suggested mashing in aluminum screws----which is the tack I took before. I'm not so sure.

What do you think I should do here? buy a tapper drill, drill out the threading, then find a screw to fit the threading?

Or mash in the screw and hope for the damn best?

I ain't yet frustrated here. I just don't have a clear picture on the way to get the igniter to send its spark correctly.
Siwash is offline   Reply With Quote
Old 03-28-2015, 12:48 PM   #9
Member
 
Join Date: Feb 2015
Posts: 76
Rewards Points: 152
Default


It'd be great of you if you could look at my recent note on this project. What do you think I should do here?
Siwash is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenmore Range Burner Problem diy1618 Appliances 9 09-02-2012 04:46 PM
Kenmore range burner ignitors not working Eagle One Appliances 16 07-24-2012 05:08 PM
Kenmore glass top burner Mary Tierney Appliances 2 12-26-2011 08:08 PM
main burner goes out after furnace running 10 -2 0 mins marion60 HVAC 4 11-02-2011 10:53 AM
Jenn Air Gas Range - One burner not sparking Dwizzo Appliances 13 09-22-2010 12:19 PM




Top of Page | View New Posts