Neon Electrical Issues - Electrical - DIY Chatroom Home Improvement Forum
Advertisement


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Electrical

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread
Display Modes
Old 06-14-2020, 04:50 PM   #1
Newbie
 
Join Date: Jul 2014
Posts: 4
Rewards Points: 14
Default

Neon Electrical issues


Hello I have a question.I have a problem with some neon lights that worked previously.The transformer light blinks and shows it has a secondary fault i think.I am trying to trouble shoot it and cant figure it out as i have basic knowledge.I replaced the transformer and the same problem.I removed the gto wire from the conduit to check if it was arcing anywhere and it was good.When i took all the wire out of the conduit and tested it.It worked fine no problem at all.When i ran the wire back through the conduit and hooked it back up it gave me the same issue.So it works when the wire is out of the conduit but not when i put it inside the conduit.The conduit has rust inside i thought that may be an issue but i have no idea.I hope someone has some knowledge they can lay on me.
alex1990 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-14-2020, 05:56 PM   #2
Newbie
 
Join Date: Jun 2020
Posts: 3
Rewards Points: 6
Default

Re: Neon Electrical issues


GTO is breaking down. What size xformer? Are you using housings? or just sleeves and boots on the electrodes? How many feet , size, and fill gas of tubes? Replace GTO and it will work again
djhutt is offline   Reply With Quote
The Following User Says Thank You to djhutt For This Useful Post:
alex1990 (06-14-2020)
Sponsored Links
Advertisement
 
Old 06-14-2020, 06:35 PM   #3
Newbie
 
Join Date: Jul 2014
Posts: 4
Rewards Points: 14
Default

Re: Neon Electrical issues


It is a 15000 volt transformer.I have wire between each piece of neon with boots on each end of the electrodes. I would say the run is about 20-25 feet long of neon.All the tubes are gassed and light up fine.It started giving me this problem a few months ago.It worked for years before that with no issue.And when i take the longest run of wire out of the conduit and hook it up when its not inside the conduit it works fine.I did replace the Gto wire coming from both sides of the transformer.You think its a wire between the neon degrading that is causing the problem.Thank you for your response.
alex1990 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-14-2020, 07:53 PM   #4
Newbie
 
Join Date: Jun 2020
Posts: 3
Rewards Points: 6
Default

Re: Neon Electrical issues


What is the exact footage of neon,# of units, the diameter in mm and the color of the gas when lit at the electrodes. 15k looks like it is too big, adding to your problems.

Last edited by djhutt; 06-14-2020 at 07:58 PM.
djhutt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Tags
conduit , neon , transformers , wire


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts