DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Plumbing (http://www.diychatroom.com/f7/)
-   -   Toilet filling slowly. Fast after twisting wall valve. (http://www.diychatroom.com/f7/toilet-filling-slowly-fast-after-twisting-wall-valve-109130/)

100n3y 06-29-2011 02:55 AM

Toilet filling slowly. Fast after twisting wall valve.
 
First and foremost, thanks for checking this out. More-so if you're able ao help! :thumbsup:

After flushing water comes up the fluidmaster and dribbles out of the top veeeeeery slowly and down the arm instead of out the hose into the fill-tube. Is that making sense?

Anyways....

When I twist the cutoff valve coming out of the wall all the way off then back on it will fill normally by going out the hose into the fill-tube. Once filled, if I flush it again, it'll dribble down the arm. The only way I can get it to fill normally is to twist the cutoff valve all the way off and back on each time.

What should I do? What's the culprit? I could pull everything out to do trial and error troubleshooting, but figured I'd ask greater minds to reduces the stress on mine. :)

oh'mike 06-29-2011 07:00 AM

Time for new guts----I suggest that you also consider a new shut of--1/4 turn ball valve----

The guts are cheap---

100n3y 06-29-2011 02:54 PM

Thanks for the reply Mike. I understand they're cheap and I guess I'll end up doing that, but for my own curiosity, mechanically, what is it that's causing it to fill normally when I turn the valve off then on again?

oh'mike 06-29-2011 08:49 PM

Likely the little valve inside is sticking---when the pressure is changed by turning the water off the valve opens.

The new guts are $10 of less and take an experienced person 10 to 12 minutes---You will have to read the instructions so plan in about 30 (unless you are a slow reader:laughing:)

100n3y 06-30-2011 02:28 AM

I'm rockin my reading at, at leeeast, a 1st grade reading level so I better hunker down and get some rations huh? ;) Preciate the help Mike!:thumbsup:

AllanJ 06-30-2011 09:42 AM

Could be something clogging the cutoff valve under the tank, that gets dislodged when you turn that valve.

Alan 06-30-2011 10:07 AM

Personally I think you might have something stuck in the diaphragm on top of the fluidmaster.

You can remedy this by

1 turning off supply from wall

2 press down and twist (gently) on the top of your fluidmaster while holding the lower portion of it so that it doesnt' twist or snap.

The plastic cap will come off, and you will be able to see if there is debris stuck inside of it.

Pull the rubber diaphragm out, hold your hand over the top of it so as not to make a mess, and turn the supply valve on just a little, to try and flush anything out that may be inside.

bob22 06-30-2011 10:49 AM

That rubber diaphragm is replaceable as well. Much easier (and pretty much the only wearable part on a Fluidmaster) than replacing all the "guts".

Lightfoot 06-30-2011 11:16 AM

Quote:

Originally Posted by bob22 (Post 677169)
That rubber diaphragm is replaceable as well. Much easier (and pretty much the only wearable part on a Fluidmaster) than replacing all the "guts".

i agree

bout 2 bucks.


All times are GMT -5. The time now is 06:37 AM.