Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-26-2013, 10:32 AM   #1
Newbie
 
Join Date: Mar 2012
Location: Eastpointe, Michigan
Posts: 29
Rewards Points: 25
Default

Spigot issues


I had a new spigot put on a couple of years ago when the old one caused a pipe to burst. I believe it was also sweated on to the copper piping. I never turn the water off to the backyard spigot during the winter time. I went to utilize my power washer and turned the water on....NOTHING AT ALL!
What could be the problem? The water did work a month or so ago. Could there be a back flow problem inside the spigot?

Thanks

Name:  ForumRunner_20130426_113054.jpg
Views: 30
Size:  37.6 KB



Name:  ForumRunner_20130426_113054.jpg
Views: 30
Size:  37.6 KB

Keith vent is offline   Reply With Quote
Old 04-26-2013, 10:39 AM   #2
Always learning...
 
fetzer85's Avatar
 
Join Date: Dec 2009
Location: Northern WV
Posts: 452
Rewards Points: 250
Default

Spigot issues


I know you said you don't normally shut the water off to that fixture but I would double check to make sure it's on. If it is, when you turn the handle do you feel tension or does it just feel like it's freely spinning? If it spins too easily make sure that handle screw in the picture is tight.

fetzer85 is offline   Reply With Quote
Old 04-26-2013, 10:49 AM   #3
Newbie
 
Join Date: Mar 2012
Location: Eastpointe, Michigan
Posts: 29
Rewards Points: 25
Default

Spigot issues


The handle is not very easy to turn. The water has never been turned off because the valve stem is stripped, need a pair of pliers to turn off.
Keith vent is offline   Reply With Quote
Old 04-26-2013, 11:07 AM   #4
Roofmaster
 
Join Date: Oct 2012
Location: Maryland
Posts: 3,635
Rewards Points: 2,028
Default

Spigot issues


You have to turn off the water to your outdoor spigots in the winter where you live. Why do you think the original pipe burst? There should be a separate valve with a bleeder inside your home about two feet inside the house.
__________________
" A lot of men build things, and a lot of things fall down "

jagans is online now   Reply With Quote
Old 04-26-2013, 11:17 AM   #5
Newbie
 
Join Date: Mar 2012
Location: Eastpointe, Michigan
Posts: 29
Rewards Points: 25
Default

Spigot issues


What's turning off the valve going to do? Im not getting water from the spigot. I did unscrew the bleeder valve a little but water began to shoot out from it. What does that bleeder valve do? Do I need to open it and let more water drain from it?

Last edited by Keith vent; 04-26-2013 at 11:20 AM.
Keith vent is offline   Reply With Quote
Old 04-26-2013, 11:37 AM   #6
Member
 
Join Date: Oct 2012
Posts: 277
Rewards Points: 256
Default

Spigot issues


I'm guessing the bleeder valve you're mentioning is inside on the shut off valve. That is there to drain down the line going outside after the valve .... once the valve is closed of course.

It's possible that the shaft that connects the handle to the actual valve located at the very last bit of the outside faucet somehow became disconnected. Google "repairing outside frost proof faucet" and you should find some information on how to disassemble the unit to figure out why you're not getting water flow.

If they don't spell it out in the instructions....... turn off the water first!
old_squid is offline   Reply With Quote
Old 04-26-2013, 11:46 AM   #7
moderator
 
TheEplumber's Avatar
 
Join Date: Jul 2010
Location: North Idaho
Posts: 7,020
Rewards Points: 2,228
Default

Spigot issues


Legend valves have had some recall issues over the last couple of years.
If the hose bib shut off valve located in the interior of the house is on I would suspect the guts of the bib has failed as Old Squid mentioned

__________________
When posting in forums, letting us know your location will help others give better feedback/advice/solutions to your questions
TheEplumber is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cold supply hums loudly, only when running outside spigot. branewrock8 Plumbing 8 01-28-2013 05:15 PM
Outside spigot question... carpenter981 Plumbing 31 10-06-2011 09:28 PM
Hot Water Heater Spigot Leak ellisje007 Plumbing 9 01-24-2009 07:52 AM
Roman Tub Spigot Problems - Phoenix Corp? bkw Plumbing 1 10-17-2008 03:21 PM
Installing a Hot / Cold Water Spigot dc2295 Plumbing 1 02-25-2008 05:10 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.