DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Plumbing (http://www.diychatroom.com/f7/)
-   -   Sears Kenmore Ultrasoft 425 Water Softener (http://www.diychatroom.com/f7/sears-kenmore-ultrasoft-425-water-softener-58652/)

greyman 12-06-2009 06:02 PM

Sears Kenmore Ultrasoft 425 Water Softener
 
Problems with auto control of regeneration. I've been through all the troubleshooting tips, cleaning and flushing of all items. This system is, and always has been clean and trouble free.
I have to put it into manual regeneration every time because it will not do it on it's own. Even when the display indicates it is going to 'recharge tonight', it never does. It seems that everything else works and senses ok. The unit counts usage fine, and all settings are ok for setup of hardness, etc. It goes into regeneration fine when I press and hold the button. It operates ok and goes through all the cycles and produces soft water.
I'm lookiing to find out why the auto function doesn't work. Only thing left in my mind is the circuit board, but cheapest I can find one is $161 plus shipping. Don't want to buy it if I'm not 100% certain that is the problem. If anyone can shed light or provide some insight to this issue I would appreciate it very much. Very frustrated at this point.

Thanks,

beenthere 12-06-2009 06:50 PM

Moved to plumbing.

Although its an appliance. You'll probably get better results here.

greyman 12-06-2009 07:28 PM

Thanks


All times are GMT -5. The time now is 12:20 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved