RUUD Powervent Water Heater Not Always Lighting - Plumbing - DIY Home Improvement | DIYChatroom


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 01-12-2010, 07:47 AM   #1
Newbie
 
Join Date: Feb 2009
Posts: 24
Rewards Points: 10
Default

RUUD powervent water heater not always lighting


I have a RUUD Powervent Model PVP50E-1 A that has been intermittently not lighting. I can hear the powervent/blower running and running (more than it should) but the burner (natural gas) does not always light and, by the time I get down there it is not even trying (spark not firing). I turn it off then back on and I can hear something click, the spark kicks in and then it lights. I would guess it is a relay clicking and going bad. Anyone had this problem? thanks

Advertisement

bloom42 is offline   Reply With Quote
Old 11-17-2014, 01:15 AM   #2
Newbie
 
Join Date: Nov 2014
Posts: 1
Rewards Points: 2
Question

RUUD powervent water heater not always lighting


Hi Bloom42,
Here in November of 2014 I have the same water heater and exactly the same problem you have described. I am wondering how you resolved it as I didn't see any replies to your post. I'm hoping it is a simple part replacement (thermostat, thermocouple, etc) that I can do myself or if a plumber is necessary.

Thanks, BigAl1954

Advertisement

BigAl1954 is offline   Reply With Quote
Old 11-17-2014, 10:35 AM   #3
Member
 
Join Date: Jan 2007
Location: Des Moines, IA
Posts: 1,145
Rewards Points: 586
Default

RUUD powervent water heater not always lighting


Quote:
Originally Posted by bloom42 View Post
I have a RUUD Powervent Model PVP50E-1 A that has been intermittently not lighting. I can hear the powervent/blower running and running (more than it should) but the burner (natural gas) does not always light and, by the time I get down there it is not even trying (spark not firing). I turn it off then back on and I can hear something click, the spark kicks in and then it lights. I would guess it is a relay clicking and going bad. Anyone had this problem? thanks
Welcome to my world....same problem, same or similar model. We are on LP, but based on what I have read and had people comment on my thread, it sounds like a gas valve issue. Gas valves for your WH are not cheap. I am having someone look at it today to give me an estimate.

Power Vent Water Heater Issues
cibula11 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bosch 1600H Tankless Water Heater natemclain HVAC 13 08-24-2009 11:33 AM
Water connections for new water heater diggerdave Plumbing 16 03-16-2009 11:36 AM
Gas Hot Water Heater - Help? MaximumAsh Plumbing 22 03-13-2009 11:57 AM
Water Heater Problems martyshel Electrical 4 01-24-2009 01:07 AM
Water Heater tsmith Plumbing 10 12-01-2008 07:24 PM




Top of Page | View New Posts