Jet Pump Losing Prime - Plumbing - DIY Home Improvement | DIYChatroom


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 07-25-2012, 10:47 PM   #1
Newbie
 
Join Date: Jul 2012
Location: Georgia
Posts: 6
Rewards Points: 10
Default

Jet pump losing prime


I have a 60ft well with a 2 line jet pump, 15ft of water in well. A few months back my pump went bad so I replaced it along with all of the piping and foot valve. I ran schedule 80 pipes so I wouldn't have to worry about the pipes breaking. About a month ago I lost prime in the well, primed it and lost prime again a few days later. Had the same problem and turned out the foot valve was bad so I replaced it. That was 2 weeks ago and here I am again with no water. What could be the problem if I have new pies with no leaks and a new foot valve?

Advertisement

jstring3 is offline   Reply With Quote
Old 07-26-2012, 10:20 AM   #2
Doing it myself
 
Alan's Avatar
 
Join Date: Apr 2006
Location: Crescent City, CA
Posts: 3,762
Rewards Points: 2,024
Send a message via AIM to Alan Send a message via MSN to Alan
Default

Jet pump losing prime


Were you able to get any water out of the pump at all after making the repairs?


did you replace the entire pipe from the foot valve all the way to the pump inlet?

Advertisement

__________________
Journeyman Plumber
Alan is offline   Reply With Quote
Old 07-26-2012, 12:16 PM   #3
Newbie
 
Join Date: Jul 2012
Location: Georgia
Posts: 6
Rewards Points: 10
Default

Jet pump losing prime


Replaced both pipes from foot valve to pump, had water for a few months then had to replace foot valve and had water for 2 weeks
jstring3 is offline   Reply With Quote
Old 07-26-2012, 09:39 PM   #4
Doing it myself
 
Alan's Avatar
 
Join Date: Apr 2006
Location: Crescent City, CA
Posts: 3,762
Rewards Points: 2,024
Send a message via AIM to Alan Send a message via MSN to Alan
Default

Jet pump losing prime


So will the pump produce water if not connected to the house?
__________________
Journeyman Plumber
Alan is offline   Reply With Quote
Old 07-26-2012, 09:48 PM   #5
Newbie
 
Join Date: Jul 2012
Location: Georgia
Posts: 6
Rewards Points: 10
Default

Jet pump losing prime


Pretty sure I have figured out the problem, I had 45lbs of pressure in my tank which was causing the pump to become air locked, installed a ball valve and closed it half way and everything seems fine now. Only bad news is that I found out that my tank is leaking water out of the bottom now so I guess that is on the list for tomorrow after work. Thanks for the responses and help
jstring3 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not sure if trying to prime my well pump correctly. jiggypiggy Plumbing 7 07-06-2012 08:14 AM
pump looses prime, runs forever, burns out PVC pipe noquacks Plumbing 19 06-04-2012 08:16 PM
Power 120V Pump from a 240V circuit RoberTX Electrical 26 07-06-2011 12:43 AM
Heat Pump will not cut off sunliner HVAC 13 05-17-2011 06:38 AM
Well Pump Problems dannyjoe Plumbing 6 10-01-2009 07:10 PM




Top of Page | View New Posts