Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-04-2010, 03:49 PM   #1
Newbie
 
Join Date: Aug 2010
Posts: 1
Share |
Default

Electric Water Heater Issues - Water Too Hot after tstat replacement and Sulfur Smell


I've been a having some issues with my electric water heater.

About 2 months ago, the temperature of the water all of the sudden became insanely hot. I did some testing and decided to replace both thermostats. That solved the problem and temps were back to normal.

About 2 weeks, after weeks of my wife complaining of a sulfur/rotten egg smell coming from the hot water, I decided to drain the tank (Which I had never done - its 7 years old) and then proceeded to flus the tank. There was lots of little white pellets that came out and once I got water back in the tank and turned it back on, the smell was completely gone.

Fast forward a week. The other night, we had no hot water, I discovered the circuit wads tripped in the breaker box. Turned it back on and everything was back to normal...but I was perplexed as to what caused that to happen. I woke up this morning and discovered that not only was the egg smell back, but the water was now insanely and dangerously hot!

Short of trashing this unit and buying a new one (i don't really want to drop $400 right now) What are my options? Did the flushing have anything to do with it? How can the t-stats not be working when they are new?

Disclaimer, the elements have never been replaced, but I'm not sure how that can affect anything. I want to get the temp back normal and the egg smell gone!

Please help! I need it!

Tim

marman4880 is offline   Reply With Quote
Old 08-04-2010, 07:04 PM   #2
moderator
 
TheEplumber's Avatar
 
Join Date: Jul 2010
Location: Idaho
Posts: 6,863
Default

Electric Water Heater Issues - Water Too Hot after tstat replacement and Sulfur Smell


Replace the magnesium anode rod to stop the smell. Its a sacrificial rod that can dissolve away over time.
The extreme hot water sounds like your thermostats

TheEplumber is online now   Reply With Quote
Old 08-04-2010, 07:56 PM   #3
Member
 
Join Date: Nov 2007
Location: Nashua, NH, USA
Posts: 6,946
Default

Electric Water Heater Issues - Water Too Hot after tstat replacement and Sulfur Smell


If the thermostat immersion part or element gets caked with sediment, regulating the temperature of the water becomes erratic.

I don't know how or why the new thermostat could get caked up so rapidly.

Do you think you got almost all the sediment and white pellets out of the tank?

Also try lowering the temperature settings (probably a screwdriver adjustment) of the thermostats.
__________________
Stop wasting time re-adjusting the pattern. Have several lawn sprinklers, one for each pattern.
AllanJ is offline   Reply With Quote
Old 08-05-2010, 09:10 AM   #4
Doing it myself
 
Alan's Avatar
 
Join Date: Apr 2006
Location: Crescent City, CA
Posts: 3,750
Send a message via AIM to Alan Send a message via MSN to Alan
Default

Electric Water Heater Issues - Water Too Hot after tstat replacement and Sulfur Smell


If the thermostat isn't touching the tank, it will overheat the water, overdraw on electrical amperage, and trip the breaker. . . .

Make sure they are touching. Sometimes when you replace them, you have to tweak the little tabs that hold them in to get them to stay tight against the tank.
__________________
Journeyman Plumber
Alan is offline   Reply With Quote
Old 08-05-2010, 04:25 PM   #5
Retired Plumbing Cont.
 
Join Date: Jul 2010
Location: Florida
Posts: 21
Default

Electric Water Heater Issues - Water Too Hot after tstat replacement and Sulfur Smell


Change the elements.
rockerjockey is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.