Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-02-2011, 12:07 PM   #1
Newbie
 
Join Date: Dec 2011
Posts: 2
Rewards Points: 0
Share |
Default

Bradford White TTW1 Hot Water Heater Problem


Hey Gurus. My hot water heater has just gone on the fritz again. A few years ago, I had problems and found that a capacitor on the Robertshaw electrical module circuit board was loose. I resoldered it and have had no problems until recently. Now, the LED light blinks constantly. I looked at the solder joins again and thought that was my problem again, but no. After resoldering, I still have the same problem. I tested all circuits and have 24V where I should. Now here is the odd thing. I unplugged the pilot sensor wire (at least I think that is what it is) and energized the circuit. The relays changed state and the electronic module made noises like it was trying to ignite the main burner. I started to reconnect the sensor wire and it arced as I got it close to the terminal and when I connected it to the terminal, the main burner ignited and it is operating. I don't know if it will reignite later. I have a manual for this heater that I found on the internet, but cannot figure out how the pilot/igniter works. I do have a constant pilot flame and the sensor touches the flame but does not touch the flame shield...like it should. Maybe a new sensor is in order? Also, if there is a pilot light, why does it click to ignite the main burner? I thought pilot lights were to ignite a main burner. Thoughts? Thanks.

Tukibird is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No hot water at any faucet, water heater working fine rivercliff Plumbing 5 10-27-2011 09:47 AM
Problem with pressure release valve in hot water heater? da_man Plumbing 3 08-16-2011 08:14 AM
any problem with cold water branch before water heater? jasperjodo Plumbing 3 06-08-2011 08:01 AM
elevate electric water heater? crankbait09 Plumbing 18 04-18-2011 11:35 AM
Bosch 1600H Tankless Water Heater natemclain HVAC 13 08-24-2009 10:33 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.