6 Stage RO Filter Trouble - Plumbing - DIY Home Improvement | DIYChatroom


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Plumbing

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 07-08-2009, 02:42 PM   #1
Newbie
 
Join Date: Jul 2009
Posts: 3
Rewards Points: 10
Default

6 stage RO filter trouble


I purchased a 6 stage Ro filter from ebay and did the install myself. I have no output from the Membrane filter to the De-orizedi 5th stage. when I took it apart I found a brass fitting on the tip of the output(not the waste line) it has a needle in the center it appears to be clogged. My water company claims 50-55 psi. I need help troubleshooting this fitting.

Advertisement

zombe1961 is offline   Reply With Quote
Old 07-08-2009, 02:48 PM   #2
Tired & Dirty
 
Join Date: Mar 2007
Location: East Central Illinois
Posts: 80
Rewards Points: 75
Default

6 stage RO filter trouble


Zombie, A picture of fitting would make helping you allot easyer.

Advertisement

evapman is offline   Reply With Quote
Old 07-08-2009, 05:52 PM   #3
Newbie
 
Join Date: Jul 2009
Posts: 3
Rewards Points: 10
Default

6 stage RO filter trouble


This is a couple of pics of the peice.
Attached Thumbnails
6 stage RO filter trouble-att00151.jpg  
zombe1961 is offline   Reply With Quote
Old 07-17-2009, 12:02 AM   #4
Member
 
Join Date: Jan 2009
Posts: 30
Rewards Points: 25
Default

6 stage RO filter trouble


That piece that you have is a check valve that is on the discharge of the membrane so that when it builds psi it does not come back into the membrane and go down the drain. It is probably fine and i would look at the automatic water shutoff. First is to take the line off that goes into the membrane and see if you have good flow and if so then that is fine. Turn it on with the output on the membrane disconnected and see if it drips any h2o out. if it doesn't than your capillary tube in the drain may be missing because you need back preasure on the drain to push product water through the membrane. If that dont work call a PROFESIONAL!! Ro's can be a pain in the A**!!
lilh2o3 is offline   Reply With Quote
Old 07-17-2009, 01:01 PM   #5
Newbie
 
Join Date: Jul 2009
Posts: 3
Rewards Points: 10
Red face

6 stage RO filter trouble


Quote:
Originally Posted by lilh2o3 View Post
That piece that you have is a check valve that is on the discharge of the membrane so that when it builds psi it does not come back into the membrane and go down the drain. It is probably fine and i would look at the automatic water shutoff. First is to take the line off that goes into the membrane and see if you have good flow and if so then that is fine. Turn it on with the output on the membrane disconnected and see if it drips any h2o out. if it doesn't than your capillary tube in the drain may be missing because you need back preasure on the drain to push product water through the membrane. If that dont work call a PROFESIONAL!! Ro's can be a pain in the A**!!

I have replaced the ASV. It makes Good water W/TDS of 30ppm 1gallon good to 4 waste. Even after the tank is full it will not shutoff. It just continues draining water.

Mike
zombe1961 is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hog Hair Filter mjbxx HVAC 10 04-10-2009 09:46 AM
Bypass Humidifier goes before or after air filter? key1cc HVAC 9 12-30-2008 10:12 AM
How to confirm 2nd stage burner working? mirob HVAC 49 12-29-2008 07:11 PM
LSI thermostat stage settings trouble! weydoggy HVAC 1 11-27-2008 10:26 AM
Trouble finding correct filter size mitchv HVAC 8 10-16-2008 08:27 AM




Top of Page | View New Posts