Go Back   DIY Chatroom Home Improvement Forum > DIY Repair > Project Showcase

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-31-2013, 09:50 AM   #1
Member
 
r0ckstarr's Avatar
 
Join Date: Jan 2013
Location: SE Texas
Posts: 1,181
Rewards Points: 674
Default

Mini-project: Rebuilt my toilet. First time doing it.


My house was built in '83. I bought it in November '12. During the inspection, we noticed that the toilet screamed when you flushed it. Not a big deal to me, I figured it was something simple in the tank. It literally screamed like a pig in pain as the water filled the tank. It was loud enough that I could hear it in the garage, or on the opposite end of the house.

Since I had other projects ahead of it, I dealt with the noise until I could get to it. A couple days ago, I noticed that the toilet would keep refilling the tank every 10mins. I could hear what sounded like water slowly trickling passed the flapper valve. I now knew that it was time to do something about it. Having never done this before, I read around online of what the causes and problems could be. It seemed pretty straightforward, and was.

First, I replaced the fill valve with the universal Fluidmaster fill valve. I adjusted it to the right height to get the water right back up to the water line in the tank. Replacing that fixed the loud screaming noise.

Then, I took the flapper off and cleaned it up and the seat for the flapper valve. The toilet still ran every 10mins. I timed it, and it was 10mins every time. So, I went and got another flapper valve. Still had the same problem with the toilet running every 10mins. (Timed it again to see if the amount of water I was losing changed). Thinking that maybe I cheaped out on the flapper, I went with a better well known brand. Still, I was losing water, and the toilet would refill briefly every 10mins.

While I was changing out this "better" flapper, I noticed something. There was a tiny bit of water still in the bottom of the tank. I happened to splash a little bit near the rubber seal of the Douglas Valve. I saw what looked like a seriously deteriorated rubber seal turn to dust and turn the water black.

I then turned the water back on and refilled the tank. I pushed down evenly on top of the fill tube, and the sound of trickling water stopped. Off with the water, flushed the toilet to empty the tank once more, then used my wet/dry vac to get out any remaining water. Time to take off the tank. I actually looked forward to doing this.

Considering the age of the house, I expected to find layers of paint behind the toilet tank since I doubt anybody would have removed the tank to paint behind it.

I was right. 2 layers of white, 1 layer of tan, and some horrid looking wallpaper.


IMGP4041 by r0ckstarr, on Flickr

I scraped what I could of the wallpaper off for now, and slapped a quick coat of white over it for the time being. When I repaint the bathroom, I will do it all correctly.

Judging by the nastiness under the tank, I would assume that the tank hadn't been taken off in years. Possibly, never.

I checked Home Depot's website and it showed that they had a new Fluidmaster Douglas Valve in stock. I went down to pick it up, and found that they did not have it in stock. Instead, they had one made by a brand called Oatey.


IMGP4049 by r0ckstarr, on Flickr

I looked in the box and noticed that it came with a clear flapper, and thought that was cool, because then I would be able to see if water was leaking passed the flapper in the future.

After cleaning up the nastiness of the toilet. I stripped everything from the tank and cleaned it inside and out. I then installed all of the new parts and put it back together. It's a very simple process, and I now have a much better understanding of how the toilet works. While I was at it, I replaced the flush handle as well.


IMGP4044 by r0ckstarr, on Flickr

I turned the water back on and gave it a test. I could clearly see water leaking passed the new flapper. I flushed 6 times, and every time this new flapper would sit down differently. I tried the chain in different positions, and still couldn't get it to seat down the same way every time. I currently have the chain directly above it, so that it lifts straight up on the flapper valve. I also timed it, and now the toilet refilled every 11 minutes! All that work, and all I gained was 1 minute?

I was frustrated with the new parts, and made a video.



You can clearly see water dripping at the bottom of the flapper valve. I flushed during the video to show. Yes, the camera is underwater. The video does not change part of the way through it. That is the water level rising over the camera.

..And, on top of that, I now had another problem. A very very slow drip from one of the tank bolts.


IMGP4051 by r0ckstarr, on Flickr

I loosened up that side of the tank and was able to fit in a wrench in there. I tightened up that bolt half of a turn and the leak stopped. Then, I leveled the tank again and have not had a drip come from it since. My fault for not tightening it enough in fear of overtightening.

I read some more online, and found some info where someone said to put a thin layer of Vaseline on the bottom of the flapper to help it seal until it wears in place. I did that, and am on my 12th hour of the toilet not running to refill again. I have flushed it at least 4 times since then and still not leaking passed the flapper.

I still have the other 2 flappers I bought (cheapo and Korky). I will save those as backup parts for the future since this isn't the only toilet in my house.

The old parts:

IMGP4047 by r0ckstarr, on Flickr

The rubber washer on the tank to bowl connection was so old and hardened, that I had to use channel locks to turn the entire thing to take it out of the tank.


Last edited by r0ckstarr; 01-31-2013 at 10:16 AM.
r0ckstarr is offline   Reply With Quote
Old 01-31-2013, 04:52 PM   #2
Solutions (handyman)
 
Join Date: Apr 2009
Location: Central Alberta Canada
Posts: 334
Rewards Points: 250
Default

Mini-project: Rebuilt my toilet. First time doing it.


Without seeing you issue first hand, I can only venture a guess based on what you say. I don't think it's the parts, as you replaced most of them, but probably the tank. Some toilets have small flaws in the material that creates either a bump or a small dip. If the flaw is where the drain is, the flapper will never completely close. As to the leak by the bolts holding the tank and base together, it's either the washer inside, the samr flaw and previously suggested, or the bolt was screwed too tight and there is a small crack. Sinplest ssolution would be to replace the entire unit. It would be under warantee ... and would work. Frustrating, but you just may end up re-doing everything again and again unless you can find the source of the problem. Good luck

Mark Harvey is offline   Reply With Quote
Old 01-31-2013, 09:32 PM   #3
Member
 
r0ckstarr's Avatar
 
Join Date: Jan 2013
Location: SE Texas
Posts: 1,181
Rewards Points: 674
Default

Mini-project: Rebuilt my toilet. First time doing it.


Quote:
Originally Posted by Mark Harvey View Post
Without seeing you issue first hand, I can only venture a guess based on what you say. I don't think it's the parts, as you replaced most of them, but probably the tank. Some toilets have small flaws in the material that creates either a bump or a small dip. If the flaw is where the drain is, the flapper will never completely close. As to the leak by the bolts holding the tank and base together, it's either the washer inside, the samr flaw and previously suggested, or the bolt was screwed too tight and there is a small crack. Sinplest ssolution would be to replace the entire unit. It would be under warantee ... and would work. Frustrating, but you just may end up re-doing everything again and again unless you can find the source of the problem. Good luck
Thanks. After the new flapper wouldn't seal, I was tempted to replace the entire toilet. I have plans to replace both with more efficient models, but not at this time as I have other things lined up.
r0ckstarr is offline   Reply With Quote
Old 02-02-2013, 09:48 AM   #4
Member
 
Join Date: Nov 2012
Location: Rochester NY
Posts: 51
Rewards Points: 75
Default

Mini-project: Rebuilt my toilet. First time doing it.


Toilets are very frustrating things to replace, between floor/waste pipe to toilet differentials and wax rings, and porcelain tanks heating up an cooling down while you try to tighten them down.... it's just a drip, crack, puddle on your floor waiting to happen. Keep trying... Good luck!
__________________

jakeubu is offline   Reply With Quote
Old 02-03-2013, 03:43 PM   #5
Member
 
r0ckstarr's Avatar
 
Join Date: Jan 2013
Location: SE Texas
Posts: 1,181
Rewards Points: 674
Default

Mini-project: Rebuilt my toilet. First time doing it.


Quote:
Originally Posted by jakeubu View Post
Toilets are very frustrating things to replace, between floor/waste pipe to toilet differentials and wax rings, and porcelain tanks heating up an cooling down while you try to tighten them down.... it's just a drip, crack, puddle on your floor waiting to happen. Keep trying... Good luck!
Thanks. The Vaseline trick seems to have worked so far. It's still not leaking passed the flapper.
r0ckstarr is offline   Reply With Quote
Old 02-03-2013, 04:03 PM   #6
Home Remodeler
 
Join Date: Dec 2007
Location: Port Orchard, Wa
Posts: 237
Rewards Points: 152
Default

Mini-project: Rebuilt my toilet. First time doing it.


Funny that fixing a toilet can make us feel so proud. DIY does that to us. Great job.
mikey48 is offline   Reply With Quote
Old 05-13-2014, 02:59 PM   #7
Member
 
r0ckstarr's Avatar
 
Join Date: Jan 2013
Location: SE Texas
Posts: 1,181
Rewards Points: 674
Default

Mini-project: Rebuilt my toilet. First time doing it.


Quote:
Originally Posted by r0ckstarr View Post
I turned the water back on and gave it a test. I could clearly see water leaking passed the new flapper. I flushed 6 times, and every time this new flapper would sit down differently. I tried the chain in different positions, and still couldn't get it to seat down the same way every time. I currently have the chain directly above it, so that it lifts straight up on the flapper valve. I also timed it, and now the toilet refilled every 11 minutes! All that work, and all I gained was 1 minute?

This thread is a little over a year old, but this problem came back. If I listen closely, I can hear what sounds like drips of water leaking passed the flapper valve. If I reach in and lightly press down on the flapper valve, the drips completely stop. Until I flush the toilet again.

The vaseline trick is only a temporary fix.

I'm currently using all of the parts above with the exception of a red Korky flapper valve that I got at the local Do It Best.

Do you think that the problem is the flapper not seating? The douglas valve I used? Or something else? I have no external leaks anywhere on the toilet.

r0ckstarr is offline   Reply With Quote
Reply

Tags
ball cock, flapper, flush valve, running, toilet repair


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Basement Toilet Gurgling zoner2009 Plumbing 4 01-30-2010 11:12 AM
Bubbles In Toilet Tank JCNimmo Plumbing 2 01-29-2010 08:11 AM
Toilet jpark Plumbing 18 01-05-2009 07:12 AM
Upstairs toilet pipe noise bliss Plumbing 8 01-10-2008 07:55 AM
Basement Toilet Floods Every Time It Rain Tmb9862 Plumbing 12 10-29-2006 10:16 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.