Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-30-2008, 06:25 PM   #76
Member
 
Join Date: Jan 2008
Location: So. IN.
Posts: 161
Rewards Points: 0
Share |
Default

Whirlpool refrig. problem


Quote:
Originally Posted by wgm View Post
Execpt same problem... but i found this fourm after the repair man just left $264 - 12-01-2007, 07:33 PM same exact pics as this post... exact same board & exact same burn & exact same symptoms... as everyone described... flickering light etc... 3 years old frig.

Whrilpool bad boards for sure someone need to start a class action suit, I am keeping my bad board in case someone does...

Great board... will start here before I call the repairman next time... even I a novice newbie ... could have changed out the control board that was clicking...

comp is offline   Reply With Quote
Old 08-27-2008, 12:59 AM   #77
Newbie
 
Join Date: Aug 2008
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


Same thing here and mine is 3 years old...thankfully I purchased a 4 year warranty!! So how do we go about starting a class action suit?? I'm in!!
depalme is offline   Reply With Quote
Old 10-08-2008, 10:49 PM   #78
Newbie
 
Join Date: Oct 2008
Posts: 2
Rewards Points: 0
Default

Whirlpool refrig. problem


I am now a proud member of the Whirpool bad board club. I feel so lucky to have purchased this fine product. Will try this fix over the week-end.
bearhunter1 is offline   Reply With Quote
Old 10-20-2008, 05:00 PM   #79
Newbie
 
Join Date: Oct 2008
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


Same model
Same defective motherboard
Same time period

The new board cost me 88.00 including shipping from OK. The old board is located in the back. Specifically at the lower left side. Uncap the white plastic box and remove the old board. Unplug the wires and plug them into the new board. Slide the new board into the white plastic box and replace the cap. Now re-install the cardboard backing to the fridge. You're good to go.

Surprisingly, my light bulbs never blew so I don't know where the surge came from.

Installation will take you 15 mins with the use of a screwdriver and small pair of pliers.
Jim
Flower Mound, TX
JBLAVERTY is offline   Reply With Quote
Old 10-24-2008, 04:29 AM   #80
Newbie
 
Join Date: Oct 2008
Posts: 2
Rewards Points: 0
Default

Whirlpool refrig. problem


I followed the instructions for bypassing the burnt section of the board (see previous posts). Worked like a charm. No $80 to $110 board replacement needed. I do have an attorney looking into a class action. I do know I will not buy Whirpool or any of their other lines. Makes it difficult because they manufacture: Roper, Magic Chef, Maytag, Kitchenaid, Jenn-air, Estate and Amana.
bearhunter1 is offline   Reply With Quote
Old 10-30-2008, 01:04 PM   #81
Newbie
 
Join Date: Oct 2008
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


Older Kenmore portable dishwasher. Drain problem. How to access beyond the plastic screen to see if there's an obstruction. The screen doesnt seem to have an obvious screw or such to undo. Is it possible that with a screwdriver it snaps open?
Back In The Saddle Again is offline   Reply With Quote
Old 10-30-2008, 08:16 PM   #82
Member
 
Join Date: Sep 2008
Posts: 94
Rewards Points: 0
Default

Whirlpool refrig. problem


I just ran accross that same simptom. The user interface board in the frig (digital display) and the light are feed from the big power board down by the compressor. Can't remember the exact tests I made but bottom line was I ordered the pwer board.
sv9779 is offline   Reply With Quote
Old 11-06-2008, 06:47 PM   #83
Member
 
Join Date: Sep 2008
Posts: 94
Rewards Points: 0
Default

Whirlpool refrig. problem


Just dropped in the power board. Problem solved. You can test the board by checking for line voltage from plug cn1 white wire to plug cn2 yellow with red striped wire. It should be 120 volts line voltage. This one was at 107 and would drop to zero when the door was opened.
sv9779 is offline   Reply With Quote
Old 12-07-2008, 09:44 PM   #84
Newbie
 
Join Date: Dec 2008
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


I just wanted to add my thanks to those posting in this thread. I have a 3-year-old Whirlpool Gold and experienced the same problem described by many here about a week ago... lights out, relay chattering when the door was opened. I ordered a new control board and installed it in about 20 mins this afternoon... and everything's back to normal. Thanks again!
CID_flyer is offline   Reply With Quote
Old 12-11-2008, 04:10 PM   #85
Newbie
 
Join Date: Dec 2008
Posts: 2
Rewards Points: 0
Default

Whirlpool refrig. problem


Whirlpool gold side by side. 3 years (warranty I bought).. digital display and light went out one month later. Took bulb out and bulb still works..
Just ordered the part and it will be here in 3 days. Scheduled a service call and cancelled .. Thanks to everyone on this thread..Would have been $75 plus part instead of $85 total...
And like someone earlier in this thread... It's not a whirlpool control board in my unit.. hmmm... something isn't right... especially when they are sending me a whirlpool replacement....
unionflanker is offline   Reply With Quote
Old 12-13-2008, 03:22 PM   #86
Newbie
 
Join Date: Dec 2008
Posts: 2
Rewards Points: 0
Default

Whirlpool refrig. problem


IF YOU HAVE A wHIRLPOOL GOLD SIDE BY SIDE WITH NO DIGITAL AND NO LIGHT AND THE FRIDGE WORKS...
$85.00 AND I DID IT MYSELF IN 5... LITERALLY 5 MINUTES.... ELECTRONIC CONTROL BOARD REPLACEMENT...
8 SCREWS FOR THE CARDBOARD AND 0 FOR THE POP OUT CONTROL BOARD...
THANKS A MILLION... EVERYONE WHO POSTED...

Last edited by unionflanker; 12-13-2008 at 03:26 PM.
unionflanker is offline   Reply With Quote
Old 12-31-2008, 08:29 PM   #87
noitall
 
HAllen's Avatar
 
Join Date: Dec 2008
Location: Central Texas
Posts: 42
Rewards Points: 0
Default

Whirlpool refrig. problem


Add me to the victim list! I bought our fridge in 2004, had to replace the ice maker previous to this. I had the same lights out on the fridge side as everyone else here but not the clicking relay.
Would it hurt to leave the yellow/red wire connected to the circuit board? I used a Scotchlock to connect the yellow/red wire (where it comes out of the frig body just below the connector) to the solid black wire in the bundle that runs across the back. No cutting needed, just slid on the connector and squeezed it on.
Everything seems back to normal so far.

Last edited by HAllen; 12-31-2008 at 08:32 PM.
HAllen is offline   Reply With Quote
Old 01-02-2009, 11:28 AM   #88
Newbie
 
Join Date: Jan 2009
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


Identical, but cooling works fine. I have an 04 that my wife bought at Lowes, light went out about a year ago and I have the chattering relay. I'm going to pull the card and see if I want to fix it - really seems pretty straight forward as I am a electrical kind of guy.

Please add me to the class action when it happens! Great info guys.
Jim
Thinfilmguy is offline   Reply With Quote
Old 01-23-2009, 07:22 PM   #89
Newbie
 
Join Date: Jan 2009
Posts: 1
Rewards Points: 0
Default

Whirlpool refrig. problem


Hi,

Just wanted to say thanks to those who came up with the fix. (pigtail red/yellow to solid black) Worked great and saved me 100 bucks.

Tom
trcons is offline   Reply With Quote
Old 01-25-2009, 11:39 AM   #90
Newbie
 
Join Date: Feb 2008
Location: n.IL
Posts: 9
Rewards Points: 0
Default

Whirlpool refrig. problem


It's been a year since the board went out in my fridge. The new board is working fine. Has Whirlpool acknowledged a problem with these yet?

4thtbird is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kohler Whirlpool not turning off tnt2006 Electrical 6 08-29-2014 09:41 PM
Kenmore Refrig. Temp. ? kourso Appliances 1 07-09-2007 11:37 AM
Post-Tension Slab Problem Advice/Help Mike McBride Building & Construction 2 01-09-2007 01:51 PM
Drywall, Mold Problem due to Leaked Water june03 Building & Construction 2 10-31-2006 07:24 AM
Problem W/ Power after Switching Outlets... G19-Fanatic Electrical 17 08-28-2006 01:55 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.