DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Appliances (http://www.diychatroom.com/f47/)
-   -   Portable Dishwasher problem (http://www.diychatroom.com/f47/portable-dishwasher-problem-4494/)

canadaclub 10-25-2006 10:09 AM

Portable Dishwasher problem
 
My portable d/w has stopped working. I can hear the motor going but it is louder than normal. I put the wash blades straight and started it up for a few minutes and when I opened the door, they were in the same spot. Is there a drive belt inside the motor-casing?

Many Thanks guys

CC

canadaclub 10-25-2006 11:10 AM

OK, an update. I removed both spray arms and checked them. I put them them back all nice and clean and now it won't drain! grrrrrr

I move the timer slowly and while it will fill with water, it won't drain. When it hits the drain cycle there is a kind of grinding sound coming from the motor.

Incidentally, it is a Frigidaire Ultra Quiet II approx. 6 yrs old.

Thanks again.

CC

jeff1 10-25-2006 05:35 PM

Hi,

Quote:

Incidentally, it is a Frigidaire Ultra Quiet II approx. 6 yrs old
Model#?

http://www.applianceaid.com/model.html Some model# helps.

jeff.

boman47k 10-26-2006 08:57 PM

Be surprised what can get in the impellers under the spray arms. If they can't turn, they can't pump the water out. If this one is like my Ultra Quiet, remove the lower spray arms and paying attention carefully remove all the plastic that will come out. Sorry, can't rememeber the names to all the pieces. But if it seems hard to come out, look for a snap like configuration. I have found plastic utensils ( forks, spoons, knives etc) in the weel in from of the pump impellor. I'm sure Jeff can be more specific if you get him a model number. Again pay close attention to how the parts come apart, strainers, etc.

amjcnf 06-03-2009 10:41 AM

I am trying to find some help regarding my Ultra Quiet II portable as well. Yesterday the bottom spray arm was "broken off", simply laying on the bottom of the dishwasher when I openned it up. My husband thought he had fixed it, as the load last night washed fine...with no banging, etc... Well, I openned it just now to run a second load since the arm incident, and it was laying on the bottom once again. I have played around with it for an hour now, trying to see if it simply "snaps" back in place, but it does not. I don't see anything broken on any of the plastic either. You can place the arm back in the center hole, but it doesn't "latch" in at all. Does anyone have any clue??

Chemist1961 06-04-2009 06:42 AM

CC, There is a removable kick plate on dishwashers for belt and motor inspection. Suggest you pull that and have a peak inside. If the belt is still in place and not slipping, with the unit unplugged try to turn the motor by hand, listening for noise and feeling for resistance. Then post your findings.:thumbsup:


All times are GMT -5. The time now is 05:06 PM.