Oven Resets/shuts Off On Its Own - Appliances - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 03-28-2009, 10:46 PM   #1
Newbie
 
Join Date: Mar 2009
Location: GTA, Ontario, Canada
Posts: 10
Rewards Points: 10
Default

Oven resets/shuts off on its own


Hello,
First post here.

I have a Kenmore electric oven that has started to randomly reset itself. It just shuts itself off while I'm using it. Sometimes it comes back on immediately with the clock flashing 88:88:88, sometimes it stays off until I operate one of the controls. There appears to be no pattern as to when it will act up. I could be using any element on the stove, or I could be using the oven.

The model number is 6817192. I don't know how old it is. The oven came with the house and I only moved in 3 months ago.

Any assistance/ideas/direction would be greatly appreciated.

Thanks

Advertisement

dukewalsh is offline   Reply With Quote
Old 03-29-2009, 06:26 PM   #2
Member
 
Join Date: Mar 2009
Posts: 53
Rewards Points: 75
Default

Oven resets/shuts off on its own


I tried to look that model up and didn’t seem to be a good model number. The problem sounds like the main board (if your range has one) but can’t say for sure because a problem like this can be hard to diagnose even if I were at your house looking at it. But I like a challenge every now and then.

Advertisement


Last edited by Scuba_Dave; 09-30-2010 at 12:48 PM. Reason: removed adv link in post
applianceman is offline   Reply With Quote
Old 03-29-2009, 09:34 PM   #3
Newbie
 
Join Date: Mar 2009
Location: GTA, Ontario, Canada
Posts: 10
Rewards Points: 10
Default

Oven resets/shuts off on its own


Thanks for checking into it. I noticed from reading other posts that the model number didn't quite look like the others from Kenmore. I guess that might mean it's very old. Also, I'm in Canada, by the way. So maybe there is a different naming convention for models in Canada.

Thanks for the link. I'll be taking a look at it.
dukewalsh is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SCARY oven fire! Why did it burn? Beth777 Appliances 70 12-08-2013 10:49 PM
Oven Blew Up at Connector with Element cynthiap Appliances 5 11-26-2008 07:30 PM
Avanti Electric Oven - But no Plug ? hongtea Electrical 4 03-16-2008 09:07 PM
Gas oven does not work; pilot light on, stovetop works fine kathleentsy Appliances 1 05-22-2007 06:05 PM




Top of Page | View New Posts