Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-17-2012, 03:25 PM   #1
Newbie
 
Join Date: Nov 2012
Posts: 2
Share |
Default

oven element not glowing all the way around


Maytag Gemini -- this is a double oven -- model # is MER6765BAB. The bottom oven lower heating (baking) element went out. It melted or burnt and the element broke.

I replaced the element and turned it on. The element glowed red or orange only about 3\4 the distance around the element.

So, I go get another. This time the element glowed red or orange only about 3/4 the distance around the element, but, this time it was on the other side of the element.

Each time the area not glowing was from the connectors until the first curve in the element.

Actually replaced the element a third time and got the same result as the 2nd above replacement.

I am assuming there is a problem somewhere else and need some guidance as to the next steps.

At the moment I am thinking the controller from reading, but there are other possibilities. Of course, hoping for the cheaper fix.

I am pretty good mechanical wise and comfortable with most electrical. I have an electrical meter but not experienced with the settings,etc.

Anyone got suggestions?

diysNovice is offline   Reply With Quote
Old 11-17-2012, 08:37 PM   #2
Member
 
Join Date: Aug 2006
Posts: 1,088
Default

oven element not glowing all the way around


Hmm, I would check for 220 consistant voltage at the terminals at the back of the element. Check for loose or damaged terminals or screws if the terminals are screw on types.

Also check for any damage at the switch terminals.

Not really a pro here, but I have worked on, bought, fixed, and sold several a few years ago.

boman47k is offline   Reply With Quote
Old 11-18-2012, 02:21 AM   #3
Member
 
Join Date: May 2012
Posts: 131
Default

oven element not glowing all the way around


If the element heats the oven then it's fine. Elements typically either work or don't. I have seen a few instances of one leg of an element contacting ground but would not be with 3 brand new elements.

If the element was only running on 110 it would not get hot enough to get red.
Protocol. is offline   Reply With Quote
Old 11-18-2012, 07:45 AM   #4
Member
 
Join Date: Aug 2006
Posts: 1,088
Default

oven element not glowing all the way around


I can't argue about the element. I do not think the element is the problem. They are either intact or not. When I checked them, I usually just checked for continuity not so much amount of resistance.

Please note I put the word consistant in bold letters. Is it possible there is a bad connection somewhere between the power block and the terminals at the element that is not making up as the elment gets to a certain temp or amp pull? Maybe at the ends of the wires feeding the element and a couple of inches back?

Maybe the wires got hot and brittle?

Not sure I have ever run into this, so I am just taking stabs in the dark.
boman47k is offline   Reply With Quote
Old 11-18-2012, 03:20 PM   #5
#1 HAWKEYE FAN
 
hardwareman's Avatar
 
Join Date: Oct 2010
Posts: 1,538
Default

oven element not glowing all the way around


bake elements do not always glow red all the way around, do not worry about it
__________________
................."I want a house that has gotten over all its troubles. I dont' want to spend the rest of life bringing up a young and inexperienced house"...........
hardwareman is offline   Reply With Quote
Old 11-18-2012, 08:23 PM   #6
Member
 
Join Date: May 2012
Posts: 131
Default

oven element not glowing all the way around


Quote:
Originally Posted by boman47k View Post
I can't argue about the element. I do not think the element is the problem. They are either intact or not. When I checked them, I usually just checked for continuity not so much amount of resistance.

Please note I put the word consistant in bold letters. Is it possible there is a bad connection somewhere between the power block and the terminals at the element that is not making up as the elment gets to a certain temp or amp pull? Maybe at the ends of the wires feeding the element and a couple of inches back?

Maybe the wires got hot and brittle?

Not sure I have ever run into this, so I am just taking stabs in the dark.
Read again. They either work or don't. There are extremely rare instances where the element wire contacts ground. But these are only with old elements, not brand new elements.

If the oven gets hot the way it is, it is perfectly fine.
Protocol. is offline   Reply With Quote
Old 11-19-2012, 05:41 PM   #7
Newbie
 
Join Date: Nov 2012
Posts: 2
Default

oven element not glowing all the way around


Here is the pic of the element not glowing. Also another pic of upper small oven element glowing entire way around.

Everything else about it seems to be ok.

I checked the terminals of the element from back side of oven with back
cover off. They were easy to get to there. I got 21.5
ohms on the element with oven off.

Turned oven on and got 246 volts at the terminals.
It also heated up to temperature fine.

Wife was worried about uneven cooking for thanksgiving etc. but I am thinking it will be ok.

Unless someone sees something out of the ordinary, I am gonna just go with it for now.

Sorry about the dirty oven pics.
Attached Thumbnails
oven element not glowing all the way around-oven-pics-002.jpg   oven element not glowing all the way around-oven-pics-003.jpg  
diysNovice is offline   Reply With Quote
Old 11-19-2012, 06:56 PM   #8
bbo
Member
 
Join Date: Feb 2010
Location: Packerland !!
Posts: 1,016
Default

oven element not glowing all the way around


does the oven get up to temp?

i'd ( and do) use an oven thermometer to ensure the temp is right.
bbo is offline   Reply With Quote
Old 11-19-2012, 11:06 PM   #9
#1 HAWKEYE FAN
 
hardwareman's Avatar
 
Join Date: Oct 2010
Posts: 1,538
Default

oven element not glowing all the way around


your spending way to much time worrying about this, it is fine.
__________________
................."I want a house that has gotten over all its troubles. I dont' want to spend the rest of life bringing up a young and inexperienced house"...........
hardwareman is offline   Reply With Quote
Old 01-12-2013, 07:47 AM   #10
Newbie
 
Join Date: Jan 2013
Posts: 1
Default

oven element not glowing all the way around


I have the same issue. I actually ran over my 1st replacement element (mailman left in in front of my garage) and was shocked that it still worked, except for the back section as shown in the photo above. I ordered another one which was guaranteed OEM (though I am suspicious). Same issue. Oven heats up and I am not too worried about it, just wondering if you have noticed any issues with yours. Uneven cooking etc.?

Thanks,
Ognar is offline   Reply With Quote
Old 01-20-2013, 07:55 AM   #11
Member
 
Join Date: Jan 2012
Posts: 210
Default

oven element not glowing all the way around


This is proper operation! Due to the placement of the electrical connection in the back corner. The back most part of the bake element is not supposed to heat up. The heating element is designed to heat the most in the front, by the door, where it is coolest, and on the sides, but not heat the back, where it stays the warmest. Convection of the heat also requires a portion of the enclosed space to be slightly cooler. Most oven manufacturers choose the back.

Take a look at other oven models and you will see the same pattern, only the electrical connection is in a different spot. My oven has two connections at either side in the back, with no portion of its W shaped coil going across the back. My moms general electric oven has the electrical connection in the center of the back. The portion of the element that traverses the back before it gets to the side does not get hot either.

av-geek is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric oven element burned out but oven still hot Dhnothandy74 Appliances 2 07-29-2012 08:29 PM
Kenmore Oven Broiler Kaput...need top fix downdraft Appliances 11 06-16-2012 11:11 PM
Kenmore Oven Element Arcing Valerie1960 Appliances 2 01-30-2012 08:03 AM
Bottom (bake) element in the oven dead? elementz Appliances 3 04-19-2010 07:40 AM
Oven Blew Up at Connector with Element cynthiap Appliances 5 11-26-2008 06:30 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.