My Whirlpool Range/oven , The Oven Won't Heat Up But Everything Else Is Working Fine - Appliances - DIY Chatroom Home Improvement Forum


Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Display Modes
Old 11-18-2012, 12:15 PM   #1
Newbie
 
Join Date: Nov 2012
Posts: 1
Rewards Points: 10
Default

my whirlpool range/oven , the oven won't heat up but everything else is working fine


my oven won't heat up at all but everything else is working fine

Advertisement

prattantina is offline   Reply With Quote
Old 11-18-2012, 04:09 PM   #2
#1 HAWKEYE FAN
 
hardwareman's Avatar
 
Join Date: Oct 2010
Posts: 1,573
Rewards Points: 1,056
Default

my whirlpool range/oven , the oven won't heat up but everything else is working fine


probably the bake element

Advertisement

__________________
................."I want a house that has gotten over all its troubles. I dont' want to spend the rest of life bringing up a young and inexperienced house"...........
hardwareman is offline   Reply With Quote
Old 11-18-2012, 09:28 PM   #3
Member
 
Join Date: May 2012
Posts: 131
Rewards Points: 75
Default

my whirlpool range/oven , the oven won't heat up but everything else is working fine


I agree, but could be a bunch of other things. Burnt wire/terminal. Depending on oven a relay on board. Switch, etc.
Protocol. is offline   Reply With Quote
Old 11-18-2012, 10:30 PM   #4
Member
 
Join Date: Nov 2012
Posts: 58
Rewards Points: 75
Default

my whirlpool range/oven , the oven won't heat up but everything else is working fine


Before you start cheking anything " make sure power is off"
RAUL HIDALGO is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat pump is not running on Heat mode frank06 HVAC 17 03-13-2012 04:34 AM
Upgraded to new Hunter model 44860 thermostat and now no emergency heat hlmaint HVAC 0 01-08-2010 02:17 PM
Heat Pump Blower always on gg_daman HVAC 1 12-16-2009 07:15 AM
Gas oven does not work; pilot light on, stovetop works fine kathleentsy Appliances 1 05-22-2007 06:05 PM
heat pump not working kyleGR HVAC 2 05-30-2006 03:35 PM




Top of Page | View New Posts