Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-17-2012, 01:45 PM   #1
Newbie
 
Join Date: Apr 2012
Posts: 1
Rewards Points: 10
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


My house is roughed in for a central vacuum system with 2 pins at each wallplate and 2 wires sticking out at the other end at the garage with a white plastic tube. I connected a Eureka Mega Boss central vacuum cannister which my friend gave me (after I have tested it, including the sweeper(powerhead) )as he upgraded. After installing the vacuum tubes to the cannister , I inserted the 2 wires into the mini-plug-ins at the cannister. When I plug in the hose at the wall plate and turn on the switch at the hose handle, the suction works but the powerhead does not turn on. I tried reversing the polarity of the 2 wires at the cannister but the problem remains the same. The power head (sweeper) is brand new and it is working when I tested it at my friend's place. What is wrong? Thanks very much


Last edited by BGees; 04-17-2012 at 01:48 PM. Reason: missed a sentence
BGees is offline   Reply With Quote
Old 04-17-2012, 02:55 PM   #2
Member
 
Join Date: Apr 2007
Posts: 531
Rewards Points: 528
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


Electric beater brush?

ktkelly is online now   Reply With Quote
Old 04-17-2012, 03:03 PM   #3
Member
 
Join Date: Mar 2011
Location: As always..beside myself.
Posts: 4,226
Rewards Points: 2,000
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


Check for any switches or buttons on the power head itself and not just at the handle switch. Mine has a large push in button right on top of the powerhead
creeper is offline   Reply With Quote
Old 04-17-2012, 09:52 PM   #4
Registered User
 
Join Date: Mar 2009
Posts: 9,968
Rewards Points: 2,000
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


Most units, two 18gauge wires are for activating only the vacuum motor for suction, to be hooked up at each remote door. Is the beater bar electric, as asked already, or run off the suction?

Gary
__________________
If any ads are present in my answer above, I do not condone/support/use the product or services listed, they are there against my permission.
Gary in WA is offline   Reply With Quote
Old 04-18-2012, 04:36 AM   #5
Member
 
Join Date: Mar 2011
Location: As always..beside myself.
Posts: 4,226
Rewards Points: 2,000
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


OP said there is a dedicated handle switch.
creeper is offline   Reply With Quote
Old 04-18-2012, 05:50 PM   #6
Registered User
 
Join Date: Mar 2009
Posts: 9,968
Rewards Points: 2,000
Default

My central vacuum suction works, but the powerhead(sweeper) does not turn on


Thanks, I see that. If no plug-in dedicated 110 for a power brush at each inlet, it works off the suction (much weaker). The slide switch on mine only activates the suction (including the power-head) turning the units motor on-off. No motor-head switch, older unit...Is your test house the exact same system?

Gary

__________________
If any ads are present in my answer above, I do not condone/support/use the product or services listed, they are there against my permission.
Gary in WA is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Central heater works only when I help jump start the motor by turning it. stanlam HVAC 10 12-11-2012 05:24 PM
Central Vacuum Wiring Rough-In ebayhoey Electrical 2 07-10-2011 03:08 PM
central vacuum amba Electrical 1 03-13-2011 05:15 PM
problem with furnace will not turn on or works by itself tech2002 HVAC 3 12-29-2010 03:36 PM
My furnace works but my air conditioner will not turn on david143kat HVAC 1 06-29-2010 06:17 PM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.