Fridaire Ele Slide In Stove - Appliances - DIY Chatroom Home Improvement Forum

Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances


Thread Tools Display Modes
Old 09-30-2013, 09:25 PM   #1
Join Date: Dec 2010
Posts: 16
Rewards Points: 20

Fridaire ele slide in stove

Oven was on preheat and pow, the 100 amp main breaker tripped. The upper top element still works after resetting the breaker. The preheat controls still light up, but get no heat from the bake element. I disconnected the leads to the bake element and get a 21.5 ohm reading.
Not sure what is normal. I tested for shorts on the incoming hot leads and they are ok. The stove is hard wired in a j-box and don't think the problem can be their because everything else is working normal.
The only thing else that may have a problem are the oven controls or a surface unit switch which is on the schematic. Any suggestions?
model # is FEF352ASF
Thanks Emmy


emmy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heat for a basement with Pellt Stove on Main Floor magnum44 HVAC 1 11-20-2011 08:55 AM
Do you have a Wood/Pellet Stove Insert with a Raised GRANITE Hearth? gmoom Remodeling 1 01-24-2011 04:54 PM
Wood Stove, and Furnace hot water system shendog HVAC 7 10-04-2010 09:30 PM
Coal Stove Hood Devil505 HVAC 1 12-06-2006 05:32 PM
Three electricans said it was impossible! Tom Electrical 35 04-29-2006 05:06 PM

Top of Page | View New Posts


Search Engine Friendly URLs by vBSEO 3.6.1