DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Appliances (http://www.diychatroom.com/f47/)
-   -   freezer not freezing (http://www.diychatroom.com/f47/freezer-not-freezing-131083/)

nbmech 01-23-2012 08:30 AM

freezer not freezing
 
Hello,
I have an Admiral NT17B8A that frosts up between the freezer and fridge. It seems to work fine for two to three months then I can see frost buildup on the coils at the bottom of the freezer. Right now th freezer stuff is soft and I need to manually defrost.
I have advanced the defrost timer and it seems to work. Is there a heater in this area I need to check?? If so, how do I do it??
Thanks

del schisler 01-23-2012 10:22 AM

Quote:

Originally Posted by nbmech (Post 831914)
Hello,
I have an Admiral NT17B8A that frosts up between the freezer and fridge. It seems to work fine for two to three months then I can see frost buildup on the coils at the bottom of the freezer. Right now th freezer stuff is soft and I need to manually defrost.
I have advanced the defrost timer and it seems to work. Is there a heater in this area I need to check?? If so, how do I do it??
Thanks

Sure if they are like most others their is a long tube with a coil inside i bet it is burnet out. Look for it it should be in their with wire nut's or hard wired if not been replaced yet. You can change these your self if you are a good diyer . Find a supplyer and take it with you and the model number also . should be no trouble putting it back. Just with wire nuts should be find. Also you say that you advanced the defrost timer and it seems to work. Now maybe the defrost timmer is not running ??? if it get's stuck in the defrost than the coil's will not cool ?? Check that also a few things to check. If you can't come up than a service call is in order

sleepyg 01-25-2012 08:39 PM

Defrost heater is out! Go to www.searspartsdirect.com and look up your freezer's model number and look at the diagram. You can see the way to get to the part from the picture. Not a hard fix, just take your time and make sure you unplug it!

nbmech 01-31-2012 08:52 AM

Thanks for the guidance.

The defrost heater arrived yesterday. It did not come with the defrost shield.
I don't remember if the shield was on top of or under the heater. My guess is on top so the heater doesn't melt the styrofoam insulation. Also, does the defrost thermostat need to touch the coils, or just be in the area of the coils?

Thanks again.

hardwareman 01-31-2012 08:59 AM

shiled goes on top and thermostat must be attached to coil

nbmech 02-01-2012 08:31 AM

Thanks.
I reinstalled the heater with the shield on top and ran the unit for a few hours. I tested the defrost cycle to make sure the heater came on and I think it got too hot as I smelled some melting styrofoam. How close should the thermostat be to the heater? The thermo cycles on at 30F and off at 80F according to the web.
Is the heater too hot? I installed #60106-34 as a replacement for 60106-25.

hardwareman 02-01-2012 06:38 PM

was the aluminum foil shield still in tact?

nbmech 02-01-2012 08:56 PM

yes its not glued on anymore but i set it on the coils between the styrofoam. is there a right side up?

hardwareman 02-01-2012 09:59 PM

nope, should be good to go.

nbmech 02-08-2012 03:51 PM

Thanks to all it seems to be working fine!!!


All times are GMT -5. The time now is 10:34 PM.