DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Appliances (http://www.diychatroom.com/f47/)
-   -   Electronic gas stove ignitor (http://www.diychatroom.com/f47/electronic-gas-stove-ignitor-174100/)

Dave Sal 03-10-2013 05:30 PM

Electronic gas stove ignitor
 
I have a Kenmore gas stove with electronic ignition that can be kind of annoying at times. There are six burners, two standard on the left, a center griddle burner divided into two sections, and one large and one small burner on the right. The two on the left side are the ones that cause problems. When I turn the knob to the "light" position, the igniter makes the click, click, click sound and a spark can be seen, after which the flame will light up. Occasionally, the front burner will fail to light and there is no spark at that electrode, but there is one at the rear. The front and rear burners are controlled by one igniter. I've checked the burner assemblies and there are no orifices that are clogged with food debris and the electrical contacts are also clear. What would cause an intermittent failure to spark on one burner?

hardwareman 03-10-2013 07:14 PM

Make sure area around the ignitor is clean . No rust, no grease no nothing. That ignitor must ground to something and if that area is no kept really clean it will not ground properly and will not produce a good spark. If this is ok you may have the spark module going bad.

Dave Sal 03-10-2013 09:19 PM

Thanks for the reply. This spark module, is it the one that controls both burners? It always seems that the rear burner gets a spark but not the front. I think I'll clean the area again just to make sure there isn't some hard to see film around the area in question.


All times are GMT -5. The time now is 07:24 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved