Ele Slide In Stove - Appliances - DIY Chatroom Home Improvement Forum

Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances


Thread Tools Display Modes
Old 10-01-2013, 03:05 PM   #1
Join Date: Dec 2010
Posts: 16
Rewards Points: 20

Ele slide in stove

Oven was on preheat and pow, the 100 amp main breaker tripped. The upper top elements still work after resetting the breaker. The preheat controls still light up, but get no heat from the bake element.
When I push either the bake or broil control on, there is no voltage coming out of the terminals on the back of the control timer.
I disconnected the leads to the bake element and get a 21.5 ohm reading.
Any suggestions?
model # is FEF352ASF
Thanks Emmy


emmy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fridaire ele slide in stove emmy Appliances 0 09-30-2013 10:25 PM
Heat for a basement with Pellt Stove on Main Floor magnum44 HVAC 1 11-20-2011 09:55 AM
Do you have a Wood/Pellet Stove Insert with a Raised GRANITE Hearth? gmoom Remodeling 1 01-24-2011 05:54 PM
Wood burning stove trim not flush against chimney Fortitude Appliances 1 11-11-2010 10:28 PM
Wood Stove, and Furnace hot water system shendog HVAC 7 10-04-2010 10:30 PM

Top of Page | View New Posts