Go Back   DIY Chatroom Home Improvement Forum > Home Improvement > Appliances

CLICK HERE AND JOIN OUR COMMUNITY TODAY...IT'S FREE!

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-11-2012, 11:28 AM   #1
DIY Homeowner
 
Barry J's Avatar
 
Join Date: Nov 2008
Location: Gardner,MA
Posts: 221
Share |
Default

Central Vac


I Have a Zenex model 275, we have two inlets and the hose does not work properly in either, when we plug it in straight it does not turn on, but if we twist it on either to the left or right slightly, it turns on. The switch on the hose does not turn it on or off, we have to untwist the hose to turn off.
Is it the switch??
Thanks
Barry

Barry J is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Add Third Timer Switch to Central Exhaust Fan MaxSteel Electrical 4 11-01-2011 02:08 PM
Central Air Conditioning running all day quaildog HVAC 26 03-14-2011 05:02 AM
Central Vac problem strongbow Electrical 4 10-23-2010 08:49 PM
Worth it for Central Air John84 HVAC 13 07-21-2009 06:00 PM
Installing Central Air using existing heat ducts lvlacic HVAC 2 06-25-2005 12:47 AM




Top of Page | View New Posts

Copyright © 2003-2014 Escalate Media. All Rights Reserved.