DIY Chatroom Home Improvement Forum

DIY Chatroom Home Improvement Forum (http://www.diychatroom.com/)
-   Appliances (http://www.diychatroom.com/f47/)
-   -   2 way panel light switch on my Whirlpool Microwave - stopped working properly. (http://www.diychatroom.com/f47/2-way-panel-light-switch-my-whirlpool-microwave-stopped-working-properly-62972/)

MikeMcGreevy 01-27-2010 11:27 PM

2 way panel light switch on my Whirlpool Microwave - stopped working properly.
 
I own a Whirlpool Microwave Model #MK7130XEQ1. It mounts above the stove and under the kitchen cabinet above.

Just recently, the 2-setting (high/low) light panel switch on the front stopped working, and after a few minutes of being left on, it will no longer turn off after it has been turned on for a few minutes, nor will it switch from high to low. It stays on the high setting only.

The only way to get the lights to go off is by unplugging the unit from the electrical outlet, waiting for a few minutes for the unit to cool off (I suppose), and then plugging the cord back into the wall.

But, of course, after a few minutes the problem repeats itself.
So, I think it is likely that a fuse or a diode or something similar has gone bad. Don't know though.

I downloaded the PDF Control Panel Parts guide from Whirlpool's support website, but this part doesn't seem to be listed or isn't shown. So I am stumped.

Thanks for an intelligent response to my post.

Suggestions are welcome.

Greatly appreciate any help on this.

mikemcgreevy@comcast.net


All times are GMT -5. The time now is 08:47 PM.


Copyright 2003-2014 Escalate Media LP. All Rights Reserved